Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I try to use the gdal raster tools, eg clipper, I get the message "The process failed to start. Either the invoked program is missing, or you may have insufficient permissions to invoke the program." I have read the forums discussing this issue, and they seem to have solved it by using multiple paths for python and pymods, separated by "/usr/bin:/Library/Frameworks/GDAL.framework/Versions/1.7/Python/"

I am not sure of what this means, but I do know that setting the path to gdal binaries in the gdal tools settings to the path above does not work.

Is there a dumbed-down version of how to correctly set the paths in qgis? Any help would be greatly appreciated. The OS I am using is OSX 10.5 (Leopard), and I am using the 'GDAL complete' package. I tried versions 1.7 and 1.8, not sure if that makes a difference.

share|improve this question
Yes! This is the exact point where I find myself (except I'm on OS X 10.6, QGIS 1.7, GDAL 1.8). Does anyone have an answer for us? – user3581 Jul 7 '11 at 19:08

the path is /Library/Frameworks/GDAL.framework/Programs which is a symbolic link to the latest version installed /Library/Frameworks/GDAL.framework/Versions/1.8/Programs

To use the commands in the console (shell):

export PATH=/Library/Frameworks/GDAL.framework/Programs:$PATH
gdalinfo ..

Or put this command in the bash_profile file

share|improve this answer
Thanks for providing an explicit and clear answer. Glad to have you here! – whuber Jul 8 '11 at 19:49

On my QGIS 1.7, here's the path:

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.