Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

we have tried to overlay a raster layer on Google map and have some difficulties to align the raster images onto the base map. When it is on the overview (Zoom level 1), it looks like this:

Overview of the raster

On a lower resolution, you could still spot the mis-alignment in high altitude area such as North Europe and Canada:

Zoom in

BUT when we zoom into the highest level, the problem has gone:

enter image description here

We have tried these approaches to address this problem:

  1. Change the projection of the raster layer on Geoserver from WGS 84 to Web Mercator, does not even shown the image on Google Map.
  2. We try to change the bbox option in the request but it returns strange results that we cannot even zoom in.

Do you have any idea why this happen? What can we do to address this problem?

Thank you very much!

share|improve this question

2 Answers 2

up vote 3 down vote accepted

try setting spericalmercator:true in the openlayers map.

share|improve this answer
    
I am calling the wms service directly on Google Map... Use the image layer and overlay it directly on the base map. –  Seen May 26 '11 at 22:46
    
make sure that you request the WMS layer in EPSG:900913 –  iant May 27 '11 at 12:03

You might try using GeoWebCache, unless your data layer is getting updated often. GWC ships with GeoServer, and will get you better performance with Google Maps. It also has a nice shortcut to make things work easier with google maps, see http://geowebcache.org/docs/current/services/gmaps.html The location of the embedded GWC is '/geoserver/gwc' instead of '/geowebcache'.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.