Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I closed the window and now I can't find it again. I've tried the Editor toolbar dropdown and Create Features is not even on there (at all, not even greyed out). Suggestions?

share|improve this question
    
Out of curiosity, do you use dual monitors? I've had a similar problem before - when my window has gotten pushed almost all the way off the screen and only a small sliver remains visible. I've also changed dual monitor settings before and had windows end up in placed that I couldn't see without changing my monitor settings back. Just a few ideas. –  Sara Barnes Jun 26 at 18:34

4 Answers 4

There are two ways to get at the Create Features window from the Editor toolbar:

1) Start Editing. Right-click on toolbar and select "Editor"

enter image description here

2) In the editor toolbar: Editor > Editing Windows > Create Features

enter image description here


Alternatively, the right most button on the editor toolbar:

enter image description here

share|improve this answer
    
I tried both of those and unfortunately they both are just not there (!). The Create Features under Editing Windows, not there, and the icon to the right of Sketch Properties icon, not there. I have already rebooted the program to no avail... tempted to reboot computer but I figured a program reboot would take care of that. (awesome visuals there btw... wish everyone answered that well!) –  MrJoshua Jun 26 at 13:55
2  
@MrJoshua One more thing: did you make sure that the editing session is active (e.g. editor > start editing) before you tried to access the Create Features window? –  Aaron Jun 26 at 14:14
    
Not that it is likely given the history of merely closing the window, but the Create Features capability can be turned off. You might see if "Create Features using templates" in the Advanced Settings Utility's Editor tab is still checked. –  johns Jun 26 at 14:34
    
@johns What is the "Advanced Settings Utility's Editor" located? –  MrJoshua Jun 26 at 16:04
1  
@MrJoshua Also note that Aaron's first step begins with "Start Editing", as his comment points out. Some tools/menu options don't even display, grayed out or not, unless you are in an edit session. There are also options in various places whether to show a button on a toolbar or not - can't recall if that's one of them (it would be under Editor Options I think). But if you are missing buttons from toolbars, that could indicate a custom profile is loaded, yours is modified (ie you accidentally deleted the button), or your profile is corrupted as suggested in the other answer. –  Chris W Jun 26 at 19:50

In Windows explorer copy and paste the following location in the address bar and replace username with your username on the machine with the arcGIS install on it.: C:\Users\username\AppData\Roaming\ESRI\Desktop10.1\ArcMap\Templates

Delete normal.mxt (your mxd template) this will restore you mxd to it stock/original format with all your toolbars and windows where they would be when you first open the mxd.

share|improve this answer
    
+1 This solution is applicable not only to this question (potentially), but is great for solving pretty much any other ArcMap interface nastiness. –  Kevin R Dyke Jun 26 at 15:24
1  
Unfortunately the address you gave, I'm stopped at \username\... then there is no appdata\... If I go through C:\Program Files\ArcGIS\Desktop10.1\Templates there is no "normal.mxt" Could that be the problem? –  MrJoshua Jun 26 at 15:59
    
I believe I had the same error as OP and this solved it. +1 @MrJoshua –  GISKid Jun 26 at 16:00
    
We even have our county GIS IT guy on it and he's baffled! –  MrJoshua Jun 26 at 16:03
    
you cant browse to this location for some reason, but it exists. copy and paste the above location in the address bar, in windows explorer, (and obviously replace "username" with your user name on the machine)and you should find normal.mxt. –  cl3 Jun 26 at 16:17
up vote 0 down vote accepted

Thanks to johns and Chris W! That was it! The Advanced Arcmap Settings under the program Utilities folder was exactly the issue! After a total program reinstall, .dll inspection, and multiple (hundreds!) of button clicks, it was the simple "Create Features using templates" checkbox. Now the real question is how did that box become unchecked? If it is some kind of feature that can be messed with within the program, why does it have to be utilized through a separate .exe program? We may never know... ;)

*here is a screen shot for future reference, along with the path listed above: Advanced Arcmap Settings program

Path to executable AdvancedArcMapSettings:

**C:\Program Files (x86)\ArcGIS\Desktop10.2\Utilities**

share|improve this answer
    
That box actually represents a Windows Registry key. It's possible that something (either in ArcGIS or another program) modified the registry directly. Third party tools can do that if they require a setting in a particular way to function. The reason they are a separate utility and not in ArcGIS is because they are registry keys, which cannot be changed from within or while their applicable program is running (hence my note about no Arc windows running). The separate .exe is just a specialized GUI that does the same thing regedit does. Also, note you can accept your own answer after 48 hours. –  Chris W Jun 26 at 21:42
    
Awesome! Thanks again Chris. –  MrJoshua Jun 30 at 14:04

The last tip with the green tick mark solve my problem.

Just to the the Untility and choose the "AdvancedArcMapSettings.exe", then check "create features using templates", reopen your arcmap, then start editors, everything works.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.