Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have an application based on Network Engineer & ArcObjects.

A part of the functionality requires users to draw a rectangle an select features. It should "add" to the current selection.

I am using a custom selection method (incorporating QueryFilter & IFeatureSelection) and selecting features in the layers. Once I am done with the selection, I open the NE Attribute Editor to see the properties of selected records, but I don't see any of the newly selected features!

I tried calling the SelectionChanged() and MakePermanent() methods and even refreshed the selection but nothing helps...

Any ideas?

PS: I have yet not tried the built-in commands. Will need some time to check if it works (I am sure it will as it is "built-in", but I don't see a reason why the feature selection does not work).

share|improve this question
OK, as expected the NE attribute editor works fine with the built-in selection tools. Now I am even more puzzled than before as to why this is not working... – ujjwalesri May 31 '11 at 10:23

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.