Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

QGIS looks straight forward except for the symbols or icons.

I have created SVG symbols and when I place my pointer to the obvious blank areas in the symbol library a pop-up says that my symbol is there, yet nothing shows in the icon library.

I insert the "ghost" svg into the map and Nothing shows on the map.

Can anyone tell me how to get an SVG file to work in QGIS?

share|improve this question
The accepted answer at this question has a link to a blog post describing the process. What are you creating your SVG symbols in? I note from this question that Illustrator may not play nice with the format. If neither of those help, you might to a search here on 'qgis svg' and see if any of the other questions/answers might. – Chris W Aug 20 '14 at 19:56

Here are points in the table of contents:

enter image description here

Here's what my SVG that I downloaded from some website looks like to Windows Explorer in my downloads folder:

enter image description here

And what it looks like in IE:

enter image description here

Now double-click your point layer to open the layer properties

  • choose the Simple Marker
  • then from the 'symbol layer type' drop-down in the upper-right, choose "SVG"

enter image description here

Now choose the little ellipse (browse button) below the SVG Groups panel, and navigate to your SVG you want to use as the symbol:

enter image description here

Now you're SVG is set as the symbol for your points, and you can adjust the size, etc:

enter image description here

And here's the result on the map:

enter image description here

share|improve this answer
Just note you can also add more SVG search paths in the Settings -> Options dialog so they will show up in the User Symbols section. – Nathan W Aug 20 '14 at 22:33

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.