Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

Sometimes the count column does populate for me, but most times it does not seem to. I haven't been able to figure out a rhyme or reason to it. There is no definition query or anything out of the ordinary. Is this a bug or is there something you can do to make sure that field is populated?

I am running ArcView 10 on Windows 7 x64.

screencapture of symbology window

share|improve this question
    
How many records are in the attribute table? –  whuber Jun 23 '11 at 3:23
    
465 records in there. –  bsigrist Jun 23 '11 at 3:29
    
Hmm... it used to be (9.x) that when there were more than 20k records, not all were read and you would get this kind of behavior. Perhaps your data are accessed over a slow network connection? –  whuber Jun 23 '11 at 3:39
    
B, Does it have anything to do with the data not being indexed? Are you working with SHP, or DB? I've noticed this to, but never had the need to get it worked out –  user3455 Jun 23 '11 at 3:51
    
Your specific question is "why" - I'm not sure about the exact conditions which cause this. But in case you're not aware of this, the workaround is to click on the Count heading, which will force ArcMap to count the features. –  Stephen Lead Jun 23 '11 at 3:53
show 3 more comments

1 Answer 1

up vote 10 down vote accepted

the workaround is to click on the Count heading, which will force ArcMap to count the features

share|improve this answer
    
This is great - did not know about that. Thanks! –  bsigrist Jun 23 '11 at 11:51
    
No problems, glad it helped. As an aside, this can be the fastest way to view the frequency distribution of your data. Rather than using the > Table > Summarize option, just create a Unique Values symbology using the field you're interested in, view the Count, then hit Cancel so you don't actually apply the symbology. –  Stephen Lead Jun 28 '11 at 2:33
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.