Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

Try to install PostGIS 2.0 from svn in Ubuntu 11.04. After running postgis.sql file I get an error:

ERROR:  could not load library "/usr/lib/postgresql/9.0/lib/postgis-2.0.so": /usr/lib/postgresql/9.0/lib/postgis-2.0.so: undefined symbol: DirectFunctionCall3Coll

PostGIS 1.5 installed without any problems.

share|improve this question
    
Could you also post all the steps you used to install ? It would help spotting the problem. –  wildpeaks Jul 3 '11 at 8:06
    
Standard steps: configure, make, make install as described in manual. PostGIS 1.5 installed correctly with the same steps. –  drnextgis Jul 3 '11 at 8:50
4  
It would be better to ask questions like this on the PostGIS forums. The question is too localized to a narrow set of circumstances. Future visitors are unlikely to find it useful. –  Sean Jul 3 '11 at 13:48
    
Right now the SVN version of PostGIS is going through some pretty big changes. If you need 2.0 for (e.g.) raster support, try using r7388 (before the GSERIALIZED_ON change) –  Mike T Jul 3 '11 at 23:31
    
I've posted this question to postgis-user maillist. –  drnextgis Jul 4 '11 at 3:17
add comment

closed as too localized by R.K., whuber Sep 28 '12 at 15:00

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

Browse other questions tagged or ask your own question.