Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I'm using ArcSDE layer in my map project in ArcMap 10. Some of the fields of this layer allow null and some don't. I can't edit the non-nullable ones, neither programmatically (IField.Editable is false) nor via Attributes panel.

Is this the restriction of SDE layers or is it possible to tweak some settings/make some changes in DB schema to allow editing of fields that can't contain null values?

share|improve this question

3 Answers 3

Here are the sdetable commands.
SDE Table
My thoughts are...
Your table is versioned?
What dbms are you using?
This esri forum Thread might point in the right direction.

share|improve this answer
    
No, my table is not versioned. Can this cause problems? Tables are stored in SQL Server 2008 R2 –  Dyppl Jul 11 '11 at 17:09
    
I'm not sure. I saw one edn doc that seemed to suggest you need a subtype. But the above forum thread suggested you can call an edit session in versioned and non-versioned gdb differently. however that was for 9.3 I would bet it has changed for 10. I would submit a support request to esri if you have that capability. –  Brad Nesom Jul 11 '11 at 18:47
    
I tried to set up versioning, but it gives me an error: "database user name and current user schema do not match". So I decided to skip it for now –  Dyppl Jul 12 '11 at 9:31
    
you are turning on versioning in arccatalog? –  Brad Nesom Jul 12 '11 at 13:48
    
@Bard Nesom: yes, I try to do it in catalog –  Dyppl Jul 12 '11 at 14:12

I'm not sure what's causing your problems, but ArcMap is perfectly happy to let you edit nullable fields in an ArcSDE database (at least on the SQL Server backend my shop uses!)

Unfortunately, I have no suggestions on solving the problem for you...

share|improve this answer

Its not something silly like fieldnames that are reserved words? I have seen something similar in the past if i recall correctly... Does it happen to all tables or just a specific one?

share|improve this answer
    
It happens to all tables. Fields that don't allow null are marked as grey in Edit Attributes panel. Shouldn't be reserved words. GlobalID is not one of them, is it? –  Dyppl Jul 12 '11 at 9:30
    
Not that I know off. Configuring geodatabases is not my strongest point really but I would try using arccatalog and check the settings of the feature class that corresponds to this table –  mapoholic Jul 12 '11 at 16:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.