Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I'm trying to do a simple MapGuide OS + Fusion overlaying Google Maps and I can't figure out why the coordinate system are off. I downloaded populated places from natural earth.

After Googling, it says that Google Maps uses WGS84 and natural earth is WGS84. Here's what I did:

I create a map definition from the natural earth data. Then I created a Flexible Layout with that map definition to view it with fusion. I checked the coordinate system of the map. It says "GCS_WGS_1984"

When I display the map, it is incorrect. (The points are way to small and do not correctly align)

How do I go about trouble shooting this? I'm brand new to GIS and I think it has to do with the coordinate systems, but as far as I can tell they should match.

share|improve this question
1  
If you zoom to the google map. What are the coordinates of your map? Do they resemble 90,-180? Or do they look more like -37555035,20423817? If the latter is true then you the google map is probably web mercator aux sphere forums.arcgis.com/threads/… –  Brad Nesom Jul 11 '11 at 19:30
    
@Brad Nesom - Oh I see now. Its in degrees - I need to convert or project it. Thanks! –  Nate Jul 11 '11 at 20:32
add comment

1 Answer 1

up vote 2 down vote accepted

Google Maps imagery is actually in the projected coordinate system Google Mercator (EPSG:900913). In some cases (e.g. KML layers), Google Maps takes WGS84 data and projects it, in other cases (e.g. an OpenLayers overlay) it doesn't. Try setting your coordinate system to EPSG:900913 and see if that solves the problem.

I'm guessing your points are clustered within about 180m of 0,0 (in the Atlantic off Africa). That likely would indicate that you're feeding WGS84 and Google Maps is expecting Google Mercator.

share|improve this answer
    
To harp again on this (sorry!), 900913 is not in the EPSG Geodetic Parameter Dataset, thus it should not be used in the form EPSG:900913. The current EPSG ID is 3857. –  mkennedy Jul 15 '11 at 20:53
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.