Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

anyone can give me an explanation about how to integrate spatialite with php(sqlite3)-windows platforms.

I have tried to refer from this link http://www.gaia-gis.it/spatialite-2.4.0-4/spatialite-cookbook/html/php.html

But I do not understand is why the error message appears as follows.

"Warning SQLite3::loadextension(), Not supported in multithreaded Web Servers"

i use libspatialite-2.dll

share|improve this question
add comment

1 Answer 1

The message is explicit. Your server settings does not support loading extension from script like so :

$db->loadExtension('libspatialite.so');

See if you could load it directly from the php.ini

share|improve this answer
    
i've done the configuration in php.ini, i edited a sqlite3.extension_dir=libspatialite-2.dll but it's just stay the same error messages. If i write the wrong code on it? Another info, i use xampp 1.7 –  user2678 Jul 16 '11 at 17:38
    
you must restart apache –  simo Jul 16 '11 at 20:58
    
i've already include it, in my way to edit the php.ini always restart my apache. but whether the problem was appear is because i using xampp, not using a php and apache which are mutually exclusive (separated each of them)? –  user2678 Jul 17 '11 at 5:16
    
check if enable_dl = On is uncommented on your php.ini. If it is and it does not still work I guess you would have to install Apache and PHP manually (which is not a big deal ....) –  simo Jul 17 '11 at 9:12
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.