Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

In an older version of ArcView, I had an add-on called Legend Limiter for my software. It would limit the legend categories to ONLY those shown in your map extent. Say for example, I have a Geology shapefile containing over 100 categories of Geology, but the extent I'm showing on my map only includes 15 categories, this tool will limit my legend to reflect ONLY the categories in my map extent. It is a great little time saver.

I installed the version found HERE. When I try to run the .exe file however, I get the prompt shown below:

Error Message

I tried googling the error message number, and the information does not resolve my issue. I did find a fix for the newer ArcView HERE. I follow the instructions from the forum to the letter, and when I add the .dll file, it's not recognized (prompt below).

enter image description here

I am officially out of ideas. I just can't get it to work. Any suggestions would be greatly appreciated. Thanks all.

share

merged by Mapperz Jul 25 '11 at 14:13

this question was merged with ArcGIS: In the Legend, show legend items that are only displayed on the map because it is an exact duplicate of that question.

migrated from meta.gis.stackexchange.com Jul 25 '11 at 13:55

This question came from our discussion, support, and feature requests site for cartographers, geographers and GIS professionals.

    
Mapperz solved this for me at gis.stackexchange.com/questions/4900/… (same question answered prior to Windows 7). Is there a way to merge the questions? The answer is posted at the link above. –  Dano Jul 25 '11 at 14:04

Browse other questions tagged or ask your own question.