Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I am trying to create a simple map of Mexico showing the state polygons and their label.

The state shapefile is from here, and the specific file is the first one from the top (Áreas Geoestadísticas Estatales (7.43 Mb)).

I edited the attribute table to create a new column with shorter state names called NOM_SHORT.

To add labels I used the "ABC" dialog as below: enter image description here

However not all states were labelled, including Oaxaca and San Luis Potosí, as shown below (painted in light grey). Why? enter image description here

Here is attribute table: enter image description here

share|improve this question
    
Did you check the attribute table to make sure all of the names migrated? –  Emily Jul 28 '11 at 15:23
    
@Emily All names are in attribute table. Maybe something to do with encoding? –  Fred Jul 28 '11 at 15:47
    
Can you post a screenshot of the attribute table? –  Emily Jul 28 '11 at 15:47
    
Do they show if you tick the Label Every Park of Multi-Part Features on the Advanced tab? –  James S Jul 28 '11 at 15:55
    
I have this exact same problem. Did you get this working? I am using v1.8. –  James S Aug 12 '11 at 11:43

4 Answers 4

Thought I would share my experience with this problem to try and help others with the problem.

I have recently had this problem, and it was fixed by running the Check Geometry Validity Tool in the Vector > Geometry Tools menu.

This found 2 errors with my data (and these were on the two polygons which were not labelling).

I fixed the geometry issues and the polygons now label correctly.

share|improve this answer
2  
I can confirm that this was the case for me too. When I fixed my geometry errors, the labels appeared as they should. –  afwatl May 23 '12 at 14:11
    
For my case as well. I had hand drawn some polygons in QGIS and managed to make them self intersecting when trying to connect the first point to the last point because I clicked wrong... –  Caroline Alexiou Mar 19 at 13:11

On the "Advanced" tab, try checking ON the button "Features don't act as obstacles for labels". This worked for me after replicating your issue.

While not a developer, I am guessing that this function is set in place so that if you have a dense set of labels, it will automatically place only enough labels to make the map legible. If you really want to force all labels on, you could go into the "Engine Settings" and check ON "show all labels (including colliding labels), however this setting resulted in poor cartographic output and overlapping labels.

share|improve this answer
    
Did not work for me, not even changing engine settings. What machine are you using? I am using Win 7 Prof. 64 bit. –  Fred Jul 28 '11 at 16:17
    
I actually downloaded your data and did the test and it did not work with your data, either. If you turn on "show label candidates for debugging" in the Engine Settings, it doesn't display even any candidate locations. I would say it is an issue with the text in those particular cases, not a labeling issue. –  RyanDalton Jul 28 '11 at 16:21
    
confirmed this too - a bug in the 'Features don't act as obstacles for labels'? –  Mapperz Jul 28 '11 at 16:45
up vote 1 down vote accepted

Though I am not a programer I think this is a bug in QGIS. My solution was to use ArcGIS for this task.

share|improve this answer

Try updating your QGis. The Latest version, 2.0.1-Dufour, has a lot of options for this:

enter image description here more of same menu

I'm guessing there are a number of ways you could handle this behavior.

  • uncheck that "Discourage Labels from Covering Features" might help
  • there's scale based visibility
  • be sure to check the colliding labels

OR just shrink your text size. That will work if nothing else does.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.