Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

This is related to a previous question of mine.

It has come to my attention that the streets file I use as my address locator in Canada uses French (or simply accented) characters for the names. These show up in similar manners to the following:

Québec
De la Riviàre-du-Lac
Franúois-de Villars

The Address product, however, uses standard (Oops, my Ameri-centrism is showing?) English characters, causing the previous examples to display like so:

Quebec
De la Riviere-du-Lac
Francois-de Villars

I believe the geocoding would fair much better if the street names actually matched via the same character set. How would you recommend I go about converting from one to the other? I have considered regex'ing it, but I thought I would ask around before I start.

P.S. It would be nice if I didn't get garbage text from French characters, regardless. All the info is stored in Geodatabases, by the way, if that matters at all. I'm on Arc10, as well.

P.P.S. It would appear that I can display accented characters just fine, but in the Shapefiles and GDB Feature Classes, they become garbage text. Is there some setting I am missing here? CURIOUS: It would seem that in one street product the names come up garbage, but in the other they display just fine.

share|improve this question
add comment

2 Answers 2

up vote 6 down vote accepted

As Jason pointed out you've got a mismatch between the character set of the data and the character set of locator. It's probably the geodb that doesn't match the data and vice versa. Make sure the geodb is in UTF-8.

If you want to retain the accented characters and still get 100% match with the unaccented spellings, store unaccented versions of the names in an alternate name table and configure your address locator to search it as well.

See Jason's links for methods of converting the names.

NOTE: Once you correct the character encoding mismatch, try the locator before creating the alternate names table. I'm not sure if it will do an automatic conversion for you.

share|improve this answer
    
Thanks for the tips. Found out that it was lacking a .cpg file. Creating one with the same name as the shp/dbf and adding "UTF-8" to it fixed the funky text issue, at least. –  Nathanus Aug 8 '11 at 21:59
    
Not sure how to fix that in a geodatabase, though. –  Nathanus Aug 8 '11 at 22:05
    
What is the encoding of the geodatabase? If it's a file geodb it should default to UTF-8 or UTF-16. –  Sean Aug 9 '11 at 14:19
    
It's set to UTF-16, but the display of the characters did not change. –  Nathanus Aug 9 '11 at 14:30
    
I'm guessing the data was imported incorrectly. Did it come from the shapefile? If so, reimport now that you've added the correct encoding to the shapefile. –  Sean Aug 9 '11 at 14:52
show 1 more comment

That isn't garbage, that's UTF-8 being displayed as CP1252.

This Stackoverflow topic may help you on your way, as may this one (if you're in Python).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.