Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I have a problem connecting to my WMS service. In ArcMap i can connect but what i see is only blank page (cannot see the layers). In Qgis it also connects with service but when i choose add layers i got this message:

alt text

Some of my WMS properties:

Geographic Coordinate System: GCS_WGS_1984

Datum: D_WGS_1984

Prime Meridian: Greenwich

Angular Unit: Degree

And i have additional question: Can i set the version of my WMS when creating in Arcgis Server ? Because what i can see is only possibility to set a WMS capability (default version is set up to 1.3.0).

I think now i know what is my problem. Look this screen from ArcInfo. Here we got (below) my WMS service and above we have got our governmental geoportal. As i can see that my WMS have no style how it should be display and i think that is why i get white page.

alt text

Do you know how i can set up a styles of display for my layers?

I do not know if it is what you expect (response from fiddler), because i never used this software but this is what i get:

HTTP/1.1 200 OK Server: Apache-Coyote/1.1 Content-Type: application/vnd.ogc.wms_xml Content-Length: 4807 Date: Fri, 20 Aug 2010 09:43:47 GMT

WMS karpaty OGC:WMS application/vnd.ogc.wms_xml image/bmp image/jpeg image/tiff image/png image/gif image/svg+xml application/vnd.ogc.wms_xml text/xml text/html text/plain application/vnd.ogc.se_xml application/vnd.ogc.se_inimage application/vnd.ogc.se_blank Layers EPSG:4326 EPSG:32634 0 KEO_boundaries KEO_boundaries EPSG:4326 EPSG:32634 default KEO_boundaries image/png 1 KEO_cities KEO_cities EPSG:4326 EPSG:32634 default KEO_cities image/png

Ad Simon Or you mean this?

alt text

Here is some problem...

share|improve this question
Sorry- messeage is in Polish language. I means that: I cannot display 1/0 because: Network connection was closed after 20 seconds. It can be affected because of problem in local network or WMS.URL server problem: http and so on. –  com Aug 20 '10 at 8:05
I assume its not a public WMS that we can test from our ends? I find Gaia a good WMS client to test in. –  Simon Aug 20 '10 at 8:27
Unfortunately it also does not work with Gaia. Exactly the same situation it connects to WMS service but when i add layers i get blank page. –  com Aug 20 '10 at 8:42
You mention your serving it up through ArcGIS Server as 1.3.0 Do you have any security enabled at the ArcGIS Server services end? What happens if you click on WMS through the REST endpoint? What happens if you do a getcapabilities request on it - does it return good looking XML? –  Simon Aug 20 '10 at 9:04
I assume that it's just that: The requests timeouts, probably because the server is slow, busy or busy-looping. That would point to a problem in the map service or server configuration. –  relet Aug 20 '10 at 9:06

3 Answers 3

up vote 2 down vote accepted

I can't help you on Qgis because I never encounter this problem. In ArcGIS, you need a patch to see WMS 1.3 layers (due to a bug), http://lab.usgin.org/applications/doc/arcmap-extension-adjust-invalid-wms-130-requests for ArcGIS 9.3.1

share|improve this answer
Unfortunately this patch did not help to solve my problem. In fact now i can get response from WMS 1.3.0 version (i have check another WMS) but it still did not work with my one... –  com Aug 20 '10 at 9:23

Are your permissions right to view the data?

share|improve this answer
yes I have permissions right to view the data. –  com Aug 22 '10 at 21:42
If you are running off of postgis make sure you have connect and select. It is possible to see the tables (connect) but not view the data (select) –  wilsongis Aug 23 '10 at 2:54

Can you download fiddler and attach a log of you trying to hit the WMS. It may yield some clues onto where the problem lies. (Comment on this thread with your results)

share|improve this answer
Sorry for my post. How can i attach a file here? Because below it is not hole response... –  com Aug 20 '10 at 9:51

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.