Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I'm trying to merge together 5 different point feature classes into one using the Merge tool in ArcGIS desktop 10. It successfully merges 3 of them but not the other 2. It comes back with an error 000594: Input feature1: falls outside of output geometry domains. These 2 feature classes are furthermost away, but still close to other feature classes.

How do I extent out the output geometry domain? I'm not seeing anything like that in the environment settings.

share|improve this question
    
Have you checked each input feature class to ensure that their Coordinate Systems all match (including zones, if applicable), and that they all have sensible values (i.e. draw them up at the same time)? –  PolyGeo Sep 1 '11 at 23:05
    
Yep, they definitely have all they same coordinate system (GCS WGS 84), so no worry on zones. They definitely all have the same data and draw fine together in the data frame. I really think it has something to do with the fact these two feature classes are furthest from all the center of all the data since the error message hints at that. –  wilbev Sep 2 '11 at 0:35
    
It's possible that the Merge tool sets itself a boundary of some sort - have you tried a Union instead? –  R Thiede Sep 2 '11 at 6:12
    
The Union tool only seems to be for polygon feature classes, these are point features. –  wilbev Sep 3 '11 at 1:07
    
Huh. Good to know. Sorry - long time since I worked in Arc. –  R Thiede Sep 3 '11 at 13:09
add comment

1 Answer

up vote 4 down vote accepted

I initially thought that the issue here has been encountered before at: http://forums.arcgis.com/threads/4525-spatial-domains-are-inconsistent-between-tools and so suggested to try creating a new features class with the same schema and an explicit & larger domain (http://help.arcgis.com/en/arcgisdesktop/10.0/help/index.html#/Defining_feature_class_properties/002200000002000000/), and then use this as the first input dataset to Merge.

However, having had the opportunity to try working with the actual data, my recommendation is to use Append rather than Merge, and to do the following (which I was able to do successfully):

  1. Create a new empty feature class (I called it AppendFC) of type Point (same as the feature classes to be merged), Coordinate System GCS_WGS_1984 (same as the feature classes to be merged) and let everything else default until you get to the last panel when you use Import (from any one of the existing feature classes to get the fields to match).

  2. Open the Append tool from the Management toolbox and use it with the five feature classes that need to be merged as the Input Datasets and the new feature class (AppendFC) as the Target Dataset. Be sure to leave Schema Type set to TEST.

On the test data sent it took just 4 seconds to Append and I believe the result is the same as what was desired from Merge. The difference is that because Append can append/merge into an existing (empty) feature class you are able to create it with the spatial domain, etc defaulting which makes it cover a much larger geographic extent than the input feature classes - but still keep the same schema.

share|improve this answer
    
I don't think that is the same issue. I tried your recommendation and had no luck with it. I'm getting the same error. I entered Lat/Long values well outside of where the point features under Environmental Settings>Geodatabase Advanced>Output XY Domain>As Specified Below... –  wilbev Sep 3 '11 at 1:25
    
Short of testing with your data (which I'm happy to try and do if it can be made available), I'm out of immediate ideas, other than that it may be worth you trying Append rather than Merge. –  PolyGeo Sep 4 '11 at 3:17
    
I would be willing to share these with you privately. Can I reach you by email? Not sure how safe it is to share email addresses on here. Thanks again for your help with this. –  wilbev Sep 5 '11 at 17:17
    
For this please use Graeme.Browning@gmail.com - I'm thinking that if you just Select a few points from each feature class and just send those 5 tiny feature classes in a file geodatabase it should be very manageable to test. Be sure to try Merge on those subsets to make sure that it still gives the error first. –  PolyGeo Sep 6 '11 at 4:13
    
Thank PolyGeo, I did get it to work using your steps. So I take it there is no way to create a larger geographic extent using the merge tool? Doesn't seem right to have to create a new feature class first to make this work with GDB when it works without doing that with SHP files. –  wilbev Sep 19 '11 at 23:55
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.