Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I have a DEM with a lot of topographic variance and a separate layer of polygon features (w/o Z values)throughout. When I use 3D Analyst to convert features(polygon) to 3D, only a portion of the polygons are overlaid. Many of the polygons seem to "be inside the DEM" or underneath, specifically the polygons that appear to be on a hillside. I've tried several extrusion methods, but can not find a clear visualization of the data. Any recommendations are welcomed.

share|improve this question

3 Answers 3

To have buildings extrude at different height values you could create a new building height elevation field (within your building polygon feature class) and then use the arcgis.rand() field calculation Python optionRandom Field Value. It will generate a random decimal number that you could multiply by 10, 20, 100, etc. Then you could use this field to indicate building height. I hope this helps. Cory

share|improve this answer
    
That works thanks. Now I am running into a problem of before not being able to see the buildings overlaid onto the DEM. I want to set the extruded buildings set to the DEM base height that exists in 3D. –  PatrickW Sep 19 '11 at 17:29
    
You will have to add a base height (the DEM) to the buildings layer as well through the layer properties. Also, on the Base Heights tab you will have to set "Use a constant value or expression:" and then click on the calculator symbol and choose your elevation field. Now it should be draped on the DEM and have individual base heights for the features. –  cmacneil Sep 20 '11 at 12:35

ArcScene has a number of options for setting the base height. It sounds like you need to set the base height of each feature to the value of the DEM in order to match the DEM terrain.

So, in the feature layer's properties, choose the Base Height tab, then choose Floating on a custom surface (ArcScene 10) or Obtain heights for layer from surface (ArcScene 9.3), and choose the corresponding surface, as below:

Setting Base Heights

If you still aren't getting the results you want, there are options for overall offsets, offsets by field, and the extrusion options you've already mentioned.

share|improve this answer

This one of many common rendering issues in ArcScene. I don't believe there is a good workaround for this other then raising the base height of the polygons slightly above the surface and even then you might still see parts of the polygons appear to be submerged or blended with the surface. I think the polygons do not retain all of the 3D information.

You could try converting the polygons to multipatch features instead. If you are still having display issues with the multipatches, go the the properties -> Rendering tab - Effects -> Select drawing priority of areal features.... Set the multipatch to render above the surface giving it a lower number then the surface underneath. This will ensure that the multipatch will draw above the surface.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.