Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I've built a model in modelbuilder but cannot find an answer to this problem. Please help if you can.

Firstly I have an 'iterate feature class' tool drawing inputs out of a folder and then selecting attributes from the input table using SQL. I am then using the "get count" tool (which counts the rows selected) to test if any attributes were selected, this is a precondition to continue the model. However, if this precondition is 'false' then the model stops. I'd like for it to just continue with the next iteration of inputs. Is this possible, and if so, any insight would be great. I was thinking I might need if-then-else logic but not sure how to use it in this setting. Please advise. Here is an image of the model.

enter image description here

Cheers, Ken!

share|improve this question
    
One thing you could explore is exporting your model as a python script, and adjusting it there. Condition checking and iterations are a lot easier in python. –  djq Nov 28 '11 at 2:23
add comment

1 Answer

Without seeing your model it seems odd that your precondition is failing. I knocked a model together (see image below) and it worked fine. When the attribute query created a selection it was copied out when nothing was selected the export was skipped. It makes me wonder if you are using the correct select tool?

Example model

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.