Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

My initial layer is an OS tif file, with its associated tfw. I can zoom into the area I want, no problem. The CRS is OS 1936 (and that's the project CRS as well).

I download a 'track' layer from an Etrex as a GPX file: I make sure the CRS is OS 1936. If I select this and zoom to the layer extent I can see it.

But I cannot see both layers at once (that is, overlaid) - although I achieved this with another similar dataset yesterday.

I'm obviously doing something wrong which I suspect is really very basic - can anyone tell me what?

share|improve this question
    
Did you drag to GPX layer to the top of the layer table of contents? Layers draw from the bottom up. Maybe your image is drawing over the GPS file? –  RyanDalton Sep 29 '11 at 22:35
    
I didn't, but it makes no difference now I have ! This si something really fundamental, staring me i the face, and it isn't CRS (see below). –  KenB Sep 30 '11 at 9:15
    
Can you upload your data anywhere for us to test? If you zoom to the GPX extent, which coordinate values are shown? –  underdark Sep 30 '11 at 10:13
    
It's something to do with the GPX co-ordinates, I think: all the CRSs are correct but a known point on the GPX (my house) is wrong. –  KenB Sep 30 '11 at 10:33
1  
gpsbabel is always my first port of call for conversions –  iant Sep 30 '11 at 15:05

3 Answers 3

your vector GPX layer needs to be above any raster layers (OS tif).

share|improve this answer

Your GPX is most certainly in WGS84. Set the project CRS to EPSG 27700, the GPX to 4326 and the raster to 27700 and enable on-the-fly reprojection.

share|improve this answer
    
OS 1936 is usually EPSG:27700 –  iant Sep 30 '11 at 8:15
    
Thanks @iant! I updated the answer. –  underdark Sep 30 '11 at 10:13
    
underdark - done all this, and thank you. The Etrex is outputting lat/long, and the subsequent GPX file is set to 4326: on the screen, and all is as you suggest. But the raster file shows as OS grid refs., whereas the GPX, despite the 'on-the-fly' setting, still shows as lat/long. –  KenB Sep 30 '11 at 11:52

When handling non-Geotiffs rasters there is no guarantee that they will be automatically loaded in QGIS with the proper CRS. This depends on how QGIS is configured in options -> CRS.

The same is true for any OGR supported format (like GPX, CSV, etc.) that has not am explicit CRS.

Out the box QGIS gives to all layers -without an explicit CRS- the WGS84 CRS, which can be right but can also be very well wrong.

So just check in the layer properties if they have the right CRS, then set whatever CRS you need for the project and enable OTFR.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.