Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I use the GeoExt QueryPanel, which I got working so far. I configured an osgeo proxy on my Apache Server, I use the override-ext-ajax.js and have the OpenLayers.ProxyHost = "/cgi-bin/proxy.cgi?url="; class configured. My problem is the following: When the QueryPanel.js sends requests to geoserver, it uses wrong URLs which I figured must be related to the QueryPanel.js file. The sent request URLs look like this:

http://localhost/cgi-bin/proxy.cgi?url=
http%3A%2F%2Flocalhost%2Fcgibin%2Fproxy.cgi%2Fwfs%3F
VERSION%3D1.1.0%26REQUEST%3DDescribeFeatureType%26TYPENAME%3Dcases%26query%3D

The request is sent via the proxy.cgi twice. The request URL should rather look like this, going passed geoserver´s WFS:

http://localhost/cgi-bin/proxy.cgi?url=
http%3A%2F%2Flocalhost%3A8080%2Fgeoserver%2Fwfs%3F
VERSION%3D1.1.0%26REQUEST%3DDescribeFeatureType%26TYPENAME%3Dcases%26query%3D

When using firebug, I can temporarily change the URLs and make the queries work! When replacing line 182

url: Ext.urlAppend(protocol.url, Ext.urlEncode({

with

url: Ext.urlAppend("http://localhost/geoserver/wfs", Ext.urlEncode({,

the describeFeatureType requests are sent the right way, but attribute queries are still using the wrong URL (localhost/cgi-bin/proxy.cgi/wfs instead of localhost/geoserver/wfs). I can´t find the responsible line for the query URLs and I´m also not really sure what to replace, since I´m quite new to JS & GeoExt. If it´s not possible to fix my problem that way, can you see another method to fix this problem?

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

I figured the source of the problem - think it was a setting that I made when having difficulties configuring a WFS. In GeoServer Globale settings, I set the Proxy Base URL to http://localhost/cgi-bin/proxy.cgi?url=, which I changed to http://localhost/geoserver now and all works fine...

Sorry for any confusion!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.