Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I work with ArcGIS 9.3. When I try to run any ArcToolbox tool I receive the message: Window Internet Explorer (Title of the Window)

"One or more ActiveX controls could not be displayed because either: 1. Your current security settings prohibit running ActiveX controls on this pages, or 2. You have blocked a publisher of one of the controls" I tried to solve the problem but I could not. Is anybody who has an idea what is going on?

share|improve this question
    
This question is asked and answered at forums.arcgis.com/threads/16854-No-arctoolbox-tools-work ("Thanks Jason! It did the trick for me too.") –  whuber Mar 15 '11 at 15:44
    
Actually a couple of more go rounds on the ESRI forums: forums.arcgis.com/threads/… and forums.arcgis.com/threads/… -- the one whuber mentions was same issue for Apple OSX on Parallels users. –  V Stuart Foote Mar 28 '11 at 18:33
1  
Did you try relaxing your Internet Explorer security settings? You said you tried to solve the problem but didn't say what exactly you've tried. –  blah238 Oct 11 '11 at 17:31
    
Yes. I enabled all the kind of ActveControls but the problem is still there. –  Demetris Oct 12 '11 at 8:49
1  
I found the solution to this problem in this post of this site:gis.stackexchange.com/questions/7275/… –  Demetris Oct 16 '11 at 14:54
add comment

3 Answers 3

There are several facets to ActiveX problems affecting ESRIs ArcGIS Toolbox. Most impact Internet Explorer ActiveX scripting or XSL of tools making calls to IE scripting. All running in the Local Security zone. These misconfigurations can impact Microsoft control panel (.CPL) and management console (.MSC) snap-ins in addition to non-Microsoft applications.

Some repairs involve verifying correct permission for the My Computer -- Zone 0 use of feature 1200 & 1400--corresponding to permit Run ActiveX controls and plug-ins or Active scripting respectively. The full listing (through IE7 is here) Microsoft KB 182569 IE8 & now IE9 have additional Zone keys.

The pseudonumeric key (inverted - L) is called a "parasite" security zone by Microsoft. An Adobe Flash upgrade has been mentioned as the culprit--but that is not proven. None the less, removal of the parasite security zone (if present) from the HKCU and HKLM Internet Settings keys is the Microsoft recommended repair to restore function to Local Zone 0 ActiveX dependent programs--like the ArcGIS Toolboxes.

It is safe. Microsoft now provides Hot Fix support in Microsoft KB 2506343

Stuart

share|improve this answer
add comment

We have ArcGIS 9.3.1 in Windows Vista Business and Windows XP at our institution. Under Vista every time we open the tools in toolbox we get AciveX warning. We just click Allow/Yes and then everything works fine as expected. Answering 'No' results in errors.

share|improve this answer
add comment

TROUBLE APPEAR

Web Browser
One or more ActiveX controls could not be displayed because either: 
1) Your current security settings prohibit running ActiveX controls on this page, or 
2) You have blocked a publisher of one of the controls. As a result, the page may not display correctly.

SOLUTION FOR :

WINDOWS 7 64 BIT, ARCGIS 10 SP.1 COULD NOT RUN ANY GEOPROCESSING ARCTOOLBOX
WITHOUT "psedonumeric key(L) in the HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Zones\ "

STEPS :

  1. wINDOWS lOGO+r,type : regedit, enter
  2. Go to HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Zones\

    zones ; key ; modify Data to

    0 1200 0

    0 1400 0

    1 1200 0

    1 1201 0

    1 1400 0

    1 1406 0

    2 1200 0

    2 1201 0

    2 1400 0

    2 1406 0

    3 1200 0

    3 1201 0

    3 1400 0

    3 1406 0

    4 1200 0

    4 1201 0

    4 1400 0

    4 1406 0

  3. Close Registry editor, restart PC/Notebook, re run ArcMap

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.