Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I am trying to Join a Mineral Database (excel) into my Attributes table. Once I do and check the Attributes, it shows up as "NULL". What is causing that, what am I not doing?

Can anyone offer suggestions/ideas as I am trying to link the .shp to that Mineral excel/database.

Thank You,

Zoran

share|improve this question
2  
Attribute Table of what software? What Version? Assume: ArcGIS (as .shp) though could be MapInfo, AutoCAD, QGIS... –  Mapperz Aug 30 '10 at 17:36
    
Could someone fix the tags for this one? –  relet Aug 31 '10 at 8:14
add comment

2 Answers 2

up vote 5 down vote accepted

The first thing I would try would be to open the Excel spreadsheet and clean out any text or cell formatting that are in it. If that does not work, export the Excel spreadsheet to a text file, then import the text file into a new Excel spreadsheet. I've had similar issues in the past and both solutions have worked. Also, make sure that the fields you are using for the join are the same data type.

share|improve this answer
add comment

I've seen this behaviour as well. If Zachary's solutions don't work (which have usually worked for me in the past), the other thing to try is to export the Excel sheet to a DBF and join that instead. I've only done this in ArcGIS, your results may vary depending on what software you're using.

share|improve this answer
1  
+1, this is my usual approach to dealing with ArcGIS's flakiness with respect to table files. –  fmark Aug 31 '10 at 3:06
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.