Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

Can anybody tell me how to install this patch in PostGIS?

http://trac.osgeo.org/postgis/ticket/413

http://trac.osgeo.org/postgis/changeset/7534

I need to use the ST_OffsetCurve function. but it seems it's not available in the PostGIS installation(I installed the version "postgis-pg90-setup-1.5.3-2").

Can anybody tell me how to make it work?

share|improve this question
    
what OS are you using. –  Nicklas Avén Oct 19 '11 at 16:53

1 Answer 1

up vote 2 down vote accepted

You'll need access to PostGIS source code, which is freely available on their site along with their binaries. Then pretty much install PostGIS again after patching the code.

The patching instructions is in the thread:

tar xvfz postgis-1.5.0.tar.gz && patch -p0 < postgis-1.5.0-RafalMagda.patch 

Then compile and install PostGIS again.

If you're on a unix environment, this is quite routine and simple.

You can also do this on Windows, but will require additional software.

see: http://trac.osgeo.org/postgis/wiki/DevWikiWinMingWSys_14_15

In step 15, you'll need to find and use a patch command similar to above.

Good luck!

share|improve this answer
    
Thanks janechii. I'm on windows. seems like a lot of work. –  WilliomT Oct 21 '11 at 4:50
    
very much so, yes lol. the linux environment already has most of those software and facilities. so it's really only a few commands. Also, the reason they have you install postGRES from source is that you need header files from there to compile postGIS. You may just need to get the appropriate header files vs reinstalling postGRES again... –  janechii Oct 21 '11 at 15:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.