Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I'm using QGIS 1.7.1 and have added a scalebar. The scalebar usually displays in degrees, unless I switch the map's projection to meters, in which case the units are display in cm. This is not correct. Any thoughts on how I can get this in reasonable units?

Thanks!

share|improve this question

2 Answers 2

up vote 2 down vote accepted

If you set the project and layer coordinate system, the scalebar will make sense. Can you share a data sample? Which coordinate systems are you using?

You say that "most of the layers do not seem to have a defined CRS". Therefore, in layer properties you have to tell QGIS which projection the layer data is in. If you set WGS84 there but the data is actually in projected coordinate system, all measurements will be screwed.

Did you get shapefiles without .prj file?

share|improve this answer
    
The project CRS is set to WGS84, most of the layers do not seem to have a defined CRS, but I have (I think) manually set them to be WGS84 by right-clicking the layers and hitting "Set layer CRS". Scalebar is still in cm. –  Richard Oct 23 '11 at 21:06
    
Not wholly sure what you mean by a data sample... I have several layers and the project file. –  Richard Oct 23 '11 at 21:06

If you change the project coordinate reference system to some other CRS with meters as its units, then the the Print Composer will be in meters, and the scalebar as well as coordinate grid will display meters (or kilometers, depending on the "Maps units per bar unit" setting).

share|improve this answer
1  
On-the-fly-projection should be checked, too. –  Andre Joost Aug 13 '12 at 12:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.