Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I just tried to register my extension for ArcGIS 10 in the 10.1 beta and it failed when I tried to register the dll: "Could not load file or assembly 'ESRI.ArcGIS.ADF.Local' Version=10.0.0.0."

Do I have to re-compile it against 10.1 dll-s in order to make it work? For the 9.x version all I had to do was to compile them against the base level (9.2) and it worked in 9.3 as well.

share|improve this question
add comment

1 Answer

Policy files which redirect applications to newer versions of ESRI assemblies are no longer distributed with ArcGIS since 10.0.

I cannot comment on the 10.1 beta specifically as I do not have it installed, but my understanding is that ESRI no longer distributes these policy files so that developers are forced to test (and recompile) their customizations on the new release. Maybe final 10.1 will include policy files which would allow redirecting 10.0 assembly references to 10.1.

If you are developing a standalone application, you can specify assembly redirects yourself in its configuration file. For ArcMap, you would need to add the redirect configuration in ArcMap.exe.config placed besides ArcMap.exe.

Also, be aware of a common misconception: lots of people seem to believe that the "Specific version" switch for an assembly reference in Visual Studio has any runtime effect. It affects VS only, not the resulting compiled assembly behavior.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.