Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

The TabbedFeatureInspector, (VB.NET), sample crashes ArcMap when I do the following:

  1. Open ArcMap.
  2. Open map document with feature class with class extension loaded.
  3. Select a feature.
  4. Start an edit session.
  5. Click the Attributes button to open the Attribute editor.
  6. Click the Create Features tab.

At this point the Create Features tab displays as a blank tab and ArcMap locks up. The wierd thing is that this only happens with the initial selection of a feature and opening of the Attribute editor. If you open the attribute editor, and then select a different feature before selecting the Create Feature tab ArcMap doesn't crash.

I initially found this by building a tabbed inspector into an application using the sample as the template. After discovering the problem I tried it in the TabbedFeatureInspector sample and found the same result.

The offending code appears to the be SetParent line in Inspect event where the inspector parent window is set to the groupbox on the user control.

Public Sub Inspect(ByVal objects As ESRI.ArcGIS.Editor.IEnumRow, ByVal Editor As ESRI.ArcGIS.Editor.IEditor) Implements ESRI.ArcGIS.Editor.IObjectInspector.Inspect

    SetParent(Me.m_inspector.HWND, Me.GroupBox1.Handle.ToInt32)
    ShowWindow(Me.m_inspector.HWND, SW_SHOW)

Any suggestions on how I can correct this?

share|improve this question
    
On further testing, if after initially selecting the Attribute tab I then select any other panel in the application before selecting the Create Feature tab, ArcMap does not lock up. It definitely appears to have something to do with the Win32 calls, SetParent and ShowWindow. Something is not occuring correctly when the inspector's parent is first set. I'm not versed in the Win32 library and have spent all day looking through MSDN trying gain some insight to whats going on. Very frustrating. –  Jeff Berry Oct 28 '11 at 22:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.