Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I am very new to GIS, so go easy on me. I am using ArcCatalog 10.0 and trying to snap a set of points to another layer that has roads in it. The points represent 10th miles along the road.

Here are the general steps for what i am doing: 1) create a new local geodatabase 2) copy my points and road layers into new GDB via copy/paste. 3) double click the snap tool in toolbox -> Editing tools 4) enter points layer as "input features", and line layer as "Snap environment".

These steps result in this error: ERROR 000800 The value is not a member of END | VERTEX | EDGE.

I have googled all over and read all the docs I could find on the ESRI site, but i can't make sense of what this error is telling me to do. does anyone have any ideas?

P.S. I also tried to create a buffer layer from the line layer using toolbox -> Analysis tools -> Proximity -> buffer and using that in the "snap environment" paramater, but i get the exact same error.

I suspect my line layer is in the wrong format, but I am stumped on my next steps. Thoughts?

share|improve this question
add comment

3 Answers

Just encountered this myself. Got it working by putting an extra set of brackets [] around my env settings. The Arc help example is misleading because they use two sets of env settings, each defined in a variable with brackets, and then they nest these variables inside brackets.

Here is the code that wasn't working:

maxDist = str(maxDist + 1) + " Meters"
arcpy.Snap_edit(pntFile,["E:/geoProjects/scaling/input/networks/HPN_split.shp","EDGE",maxDist])

...and the code that is working: maxDist = str(maxDist + 1) + " Meters"
arcpy.Snap_edit(pntFile,[["E:/geoProjects/scaling/input/networks/HPN_split.shp","EDGE",maxDist]])

share|improve this answer
add comment

I know this is a year old, but I figured out the easy way. It will give you that error no matter what shapefile you bring in as the snap environment. You need to select a type of snapping from the drop down menu and enter a distance tolerance next to your file where it comes up underneath the snapping environment. Hope this helps someone!!

share|improve this answer
add comment

Nov-01:

Is it possible to share a portion of your line and point, let me try that.. Because i am not able to replicate or any document on this error code. try to attach the file in your reply or if not possible to attach, send it to me vadivelan.gis@gmail.com

Could you try with exporting the point and line features into the file geodatabase. I didn't understand "new GDB via copy/paste".

share|improve this answer
    
i just now created a fresh geodatabase. I right clicked both layers and did an "Export -> To geodatabase (single)", and sent them to the new feature dataset in the new geodatabase. I get the same error when trying to snap. –  bostonBob Oct 31 '11 at 21:08
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.