Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I am new to qgis and I would like to create a buffer around point features.

My goal is to create a quarter mile buffer (402.336m) around each point feature, using Geoprocessing Tools -> Buffer(s), setting the buffer distance and exporting. The process creates what appears to be a massive polygon. However when I use '.05' as the distance buffers appear around each point.

I assumed this happened because the measurement units are not correct. I verified the project projection (NAD83 OH/South). Then I checked the Measure Tool via Options -> Map Tools. Te ellipsoid for distance calculations set at WGS 84 and the Preferred Measurement Units is set to 'meters'

I have set up 'on the fly' projections

How do I solve the mystery of this buffer problem?

Setup: qgis 1.7, Ubuntu 11.04

share|improve this question
add comment

3 Answers

up vote 3 down vote accepted

You have to reproject your point input data to NAD83. FTools doesn't care at all about the project settings. The buffer will be created in layer units.

share|improve this answer
    
the buffer function still does not appear to be aware of the measurement units. I reprojected by selecting layers right-click -> Save As and select the projection of the project. It works for some layers but not others. –  rhodee Nov 4 '11 at 21:31
add comment

I am using v 1.8 and had similar problems buffering polygons. SHP projection was NAD83 and the buffer function did not recognize map units. I used a buffer of 0.00015 degrees for a shapefile located north of the 49th parallel. I played with the buffer amount quite a bit and found it useful to start at 0.005 and work my way down by decreasing orders of magnitude (0.0005, 0.00005) then pick a number in between that gave me the effect I wanted.

Of course you can always do the math, too.

share|improve this answer
    
Please see @whuber's comment to Tomek's answer. The same principle applies to your answer. –  RyanDalton Apr 26 '13 at 19:40
add comment

I gave up on the layer projection. You can simply use the conversion rate: 1m =~ .000009 degrees.

share|improve this answer
4  
At most places in the world this produces unsatisfactory results, because the conversion from degrees to meters depends (very strongly) on location and orientation. Because you are near the Equator where the discrepancy is relatively small, if you are using this procedure for local work you might not notice (or even care about) the errors. –  whuber Jun 17 '12 at 13:28
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.