Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I get an error when trying to warp a tif file in QGIS:

ERROR 1: Too many points (35721 out of 35721) failed to transform, unable to compute output bounds.

I am using QGIS 1.7.0 Wroclaw with gdal 1.8. I am trying to reproject from ETRS89 to HD72 EOV. There was an error in the data, with the UTM zone added to the eastings. That is, the x coordinates read 34327213.050 when they should read 327213.050 in UTM zone 34N. I have tried changing the .tfw file but this did not help. Then I translated the tif to a .vrt and edited the vrt, removing the rogue 34, and fixing the extent. This also did not help - I still get the same error when I try to warp. In layer properties, this raster now has the same origin, extent and SRS as other similar rasters, but only this one gives the error.

How do I work this out?

A similar question (Setting projection of tif file in QGIS?) was asked 4 months ago, but it was not the exact same problem, and the OP did not explain how the problem was resolved.

share|improve this question

So here is the quick and dirty solution to my problem. I have both a *.tif and *.twf for each raster. Combining several suggestions I saw on other sites, I opened the GeoTiffs in a photo editor (PSP 5 in my case, but gimp would also work) and saved as a plain tiff, thereby removing the metadata. Then I edited the .twf to remove the 34 in the easting, and saved this with the same name as the new, non-georeferenced tiff. QGIS then looked to the twf file for the geographic info, and I was able to re-project the rasters.

Edit: Or, alternatively, one could get a little program called geotiff examiner, and use that to update the referencing for the tif and the twf. All it does is modify the geo tags. Or, one could use the method described in the answer by MerseyViking.

share|improve this answer

Have you tried using gdal_translate to fix the error? Something like this should work:

gdal_translate -a_srs EPSG:32634 -a_ullr <actual coordinates go here> broken.tif fixed.tif

The order of the coordinates should be: left, top, right, bottom.

This should ignore everything that's in the TIFF's metadata and overwrite it with the proper bounds and projection. Also, by default, it'll embed the bounds in the TIFF rather than relying on a .tfw, so don't worry if one isn't created with your new file.

A link to the previous question might be useful, even if its not exactly the same issue.

share|improve this answer
Thanks! I will try this as soon as I get a chance, because I think it sounds like a better long-term option. In the meantime, I discovered the work-around described in my answer. – Rudi Nov 22 '11 at 0:03

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.