Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I was playing around with uDIG and realized that its WMS capabilities are awesome! The Global Mosaic perfectly fits a map I created! However, I was planning to use the WMS layer as an orientation for cleaning up my polygons, yet geoprocessing (merge etc.) is not very much straightforward in uDIG (is it?).

Therefore I wanted to load the WMS into QGIS (1.7.2). After I set up the connection as http://wms.jpl.nasa.gov/wms.cgi?

the connection works but when loading any service I get the following response:

Antwort: <?xml version='1.0' encoding="UTF-8" standalone="no" ?>
<!DOCTYPE ServiceExceptionReport SYSTEM "http://wms.jpl.nasa.gov/exception_1_1_1.dtd ">
<ServiceExceptionReport version="1.1.1">
<ServiceException>
This server no longer provides full WMS services!
</ServiceException>
</ServiceExceptionReport>  

can anyone suggest a solution for correctly loading this WMS into QGIS? thank you!

Jens

share|improve this question
    
"This server no longer provides full WMS services!" -> the service was discontinued by NASA. The server uDIG is using is probably another one, just copy the URL and use it to add a new connection in QGIS. –  Giovanni Manghi Dec 2 '11 at 15:12
add comment

2 Answers

JPL don't provide a WMS service any more (the clue is in the error message). I believe that what you have in UDig is some sort of tile service like WMTS or TMS.

This thread suggests that you need to use GDAL to load a TMS layer into QGis.

share|improve this answer
    
QGIS supports tiled wms servers out of the box. Just add them as any other wms server. –  Giovanni Manghi Dec 2 '11 at 15:10
    
TMS and WMTS are different beasts to a tiled WMS. –  iant Dec 2 '11 at 15:13
    
is Tilecache a TMS or tiled WMS server? –  Giovanni Manghi Dec 2 '11 at 15:29
    
I quickly understood that the NASA server was shut down. I was mainly wondering where uDIG get´s the data from. In case the JPL server is down, where do the tiles come from? The ID in uDIG refers to something on my "localhost". nevertheless, thank you for your response –  Jens Dec 4 '11 at 10:08
add comment

@Jens - Have you tried JPL's OnEarth WMS? This has the global mosaic layers.

http://onearth.jpl.nasa.gov/wms.cgi?

share|improve this answer
    
Hi, when I add your suggest URL, then I still get this error: "Map request error (Status: 200; Response: <?xml version='1.0' encoding="UTF-8" standalone="no" ?> <!DOCTYPE ServiceExceptionReport SYSTEM "wms.jpl.nasa.gov/exception_1_1_1.dtd "> <ServiceExceptionReport version="1.1.1"> <ServiceException>" Meaning, it still looks for wms.jpl.nasa.gov... –  Jens Dec 7 '13 at 15:12
    
onearth.jpl.nasa.gov/wms.cgi?request=GetTileService this is the WMTS endpoint. –  BJ Marraccini Dec 7 '13 at 18:54
    
onearth.jpl.nasa.gov/… -- this a sample WMS request for image response. –  BJ Marraccini Dec 7 '13 at 18:55
    
onearth.jpl.nasa.gov/tiled.html - this describes JPLs movement from WMS to a prototype GetTileRequest (WMS-T, WMTS) for the short term. The links in my earlier comments above are from this page. –  BJ Marraccini Dec 7 '13 at 19:03
    
very interesting! I will try it out today once more. thx! –  Jens Dec 9 '13 at 6:50
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.