Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using QGIS 2.0.1 running off of a Ubuntu computer.

I have been going through some basic tutorials (http://fossgeo.org/free-qgis-courses/) and have come up against a small and silly little obstacle. Some of the problems and examples involved in these tutorials require specific CRS presets. When I first started working, my copy of QGIS had all of the different CRS types that came up. However, after a few days something appears to have happened and I no longer have access to a bunch of the CRS types referenced in the tutorials. I have tried looking them up by name and EPSG# to no avail. I have tried reinstalling the program.

I have not been able to find a download or plugin to restore all of the CRS presets, does such a thing exist?

share|improve this question

This looks like a broken installation.

QGIS stores CRS information in a spatialite database srs.db. During installation, it synchronizes this database with CRS information from GDAL using a tool named crssync.

On Ubuntu, you find the files in /usr/share/qgis/resources and /usr/lib/qgis. You might need admin priviliges to change or run them.

QGIS for Windows standalone has the files in C:\Programs\<QGIS version>\apps\qgis\resources and C:\Programs\<QGIS version>\apps.

It might help to rerun crssync, or re-install GDAL and QGIS to get the database back.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.