Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

i read all the questions with 500 server error i could find on the net but nothing seems to solve my problem:

I installed qgis and all depending packages on a debian server. The first REQUEST=GetCapabilities worked fine and i created a qgs project file in qgis desktop on my windows workstation.

Then i moved the project file + shapefiles to the cgi-bin directory and changed the permissions to do everything for everyone.

Calling REQUEST=GetCapabilities then gave me a nice output but no layers.

The problem was I forgot to change the path to the shp files. After changing it and retrying the REQUEST=GetCapabilities i got the 500 internal server error.

In apache log it only says "premature end of script headers: qgis_mapserv.fcgi" - nothing else. no missing libary.

To make sure it wasn't something with a specific shapefile i created a project with a single raster layer and a png file. I copied both to my cgi-bin folder again. And surprise. This is working. I get my raster image displayed

I also tried to put the shapefiles into my home directory and pointed the path in the project file there --> 500

tried absolute and relative pathes in project file --> 500

Any ideas why qgis desktop is working with my shapefiles but qgis server doesn't?

share|improve this question
    
now i have tried to use a gpx file in a vector layer --> 500. It seems that qgis server has some specific problem with vector layers. any ideas how to solve this? –  Daniel Jan 19 '12 at 12:13
    
Maybe same as here: osgeo-org.1803224.n2.nabble.com/… –  underdark Jan 19 '12 at 12:41
    
Perhaps when running in qgis server, the credentials are different, and, therefore the privileges to certain folders and files are restricted. e.g. the actual vector files themselves and/or temporary and intermediate directories are no longer accessible? –  Stephen Quan Jan 25 '12 at 15:22
    
Try to put IPCCommTimeout 120 in VirtualHost section –  user6832 Apr 9 '12 at 12:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.