Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I'm importing data from my OSM file to a postgresql database using osm2pgrouting. I followed everything in from here and it went smoothly, until I try using osm2pgrouting. This is what happens:

root@niceroute:/opt/osm2pgrouting# ./osm2pgrouting -file ncr.osm -conf mapconfig.xml -dbname niceroute -user postgres -host localhost
host=localhost user=postgres dbname=niceroute port=5432
connection failed

I looked in many forums but still I don't have the answer I'm looking for. Please help me. Thanks!

UPDATE: My pg_hba.conf file:

# PostgreSQL Client Authentication Configuration File
# ===================================================
#
# Refer to the "Client Authentication" section in the
# PostgreSQL documentation for a complete description
# of this file.  A short synopsis follows.
#
# This file controls: which hosts are allowed to connect, how clients
# are authenticated, which PostgreSQL user names they can use, which
# databases they can access.  Records take one of these forms:
#
# local      DATABASE  USER  METHOD  [OPTION]
# host       DATABASE  USER  CIDR-ADDRESS  METHOD  [OPTION]
# hostssl    DATABASE  USER  CIDR-ADDRESS  METHOD  [OPTION]
# hostnossl  DATABASE  USER  CIDR-ADDRESS  METHOD  [OPTION]
#
# (The uppercase items must be replaced by actual values.)
#
# The first field is the connection type: "local" is a Unix-domain socket,
# "host" is either a plain or SSL-encrypted TCP/IP socket, "hostssl" is an
# SSL-encrypted TCP/IP socket, and "hostnossl" is a plain TCP/IP socket.
#
# DATABASE can be "all", "sameuser", "samerole", a database name, or
# a comma-separated list thereof.
#
# USER can be "all", a user name, a group name prefixed with "+", or
# a comma-separated list thereof.  In both the DATABASE and USER fields
# you can also write a file name prefixed with "@" to include names from
# a separate file.
#
# CIDR-ADDRESS specifies the set of hosts the record matches.
# It is made up of an IP address and a CIDR mask that is an integer
# (between 0 and 32 (IPv4) or 128 (IPv6) inclusive) that specifies
# the number of significant bits in the mask.  Alternatively, you can write
# an IP address and netmask in separate columns to specify the set of hosts.
#
# METHOD can be "trust", "reject", "md5", "crypt", "password", "gss", "sspi",
# "krb5", "ident", "pam" or "ldap".  Note that "password" sends passwords
# in clear text; "md5" is preferred since it sends encrypted passwords.
#
# OPTION is the ident map or the name of the PAM service, depending on METHOD.
#
# Database and user names containing spaces, commas, quotes and other special
# characters must be quoted. Quoting one of the keywords "all", "sameuser" or
# "samerole" makes the name lose its special character, and just match a
# database or username with that name.
#
# This file is read on server startup and when the postmaster receives
# a SIGHUP signal.  If you edit the file on a running system, you have
# to SIGHUP the postmaster for the changes to take effect.  You can use
# "pg_ctl reload" to do that.

# Put your actual configuration here
# ----------------------------------
#
# If you want to allow non-local connections, you need to add more
# "host" records. In that case you will also need to make PostgreSQL listen
# on a non-local interface via the listen_addresses configuration parameter,
# or via the -i or -h command line switches.
#




# DO NOT DISABLE!
# If you change this first entry you will need to make sure that the
# database
# super user can access the database using some other method.
# Noninteractive
# access to all databases is required during automatic maintenance
# (custom daily cronjobs, replication, and similar tasks).
#
# Database administrative login by UNIX sockets

# JA: Set local database connections to "trust" in "pg_hba.conf" to be able to work with PostgreSQL as user "postgres". 
#local   all         postgres                          ident sameuser
local   all postgres    trust

# TYPE  DATABASE    USER        CIDR-ADDRESS          METHOD

# "local" is for Unix domain socket connections only
# JA: change to solve isssue on osm2pgrouting 
#local   all         all                               ident sameuser
local   all         all                               trust
# IPv4 local connections:
host    all         all         127.0.0.1/32          md5
# IPv6 local connections:
host    all         all         ::1/128               md5

I hope this will make things clearer. :D

share|improve this question
add comment

2 Answers

up vote 4 down vote accepted

It's a problem with postgresql. You can solve it by editing pg_hba.conf with

sudo nano /etc/postgresql/8.x/main/pg_hba.conf

where 8.x depend of your postgresql version (8.4 on Lucid Lynx)

You change in the column METHOD of the file the word ident by trust and save the file.

After you do a

sudo /etc/init.d/postgresql-8.x restart

Your pgrouting command now works.

Be cautious, the tip I give you open a security issue : Ok only on a dev server at office

share|improve this answer
    
thanks for the answer. I edited my question to include my current pg_hba.conf file. I already did your suggestion, but still it did'nt work. Did I edit the file right? –  jalbautista Sep 14 '10 at 15:30
    
A mistake in my previous answer ...(I correct it). If you have problem after this first change, substitute md5 to trust in your configuration file. –  ThomasG77 Sep 14 '10 at 15:51
    
Thanks a lot @Thomas it worked! :D. –  jalbautista Sep 14 '10 at 16:45
    
I think the save version would be to run osm2pgrouting with a registered Postgres user instead of with root. –  underdark Sep 15 '10 at 9:23
1  
For linux users beginners, it means do a "sudo su postgres" and launch your usual osm2pgrouting command line after. I don't do the test but I suppose it's what @underdark tells by his previous comment. It work's too? –  ThomasG77 Sep 16 '10 at 7:34
add comment

I ran into a similar issue tonight. In my case the solution was that my database had a password and osm2pgrouting needing the -passwd parameter.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.