Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have converted many KML files to layer in ArcGIS many times before without any problem. I just did a conversion (Arc Toolbox>Conversion tools> KML to layer) and the file is showing up in the table of contents but there is no layer. Any ideas or suggestions?? enter image description here

share|improve this question
is it possible there are no features in the KML? What does it look like in Google Earth? – Jakub Jan 24 '12 at 18:24
Try right-clicking on the layer and choosing "Zoom to extent" (or similar command, I don't remember the exact wording and don't have Arc in front of me now). If you find the data, but offset from where it should be, you may need to set the spatial reference system of your data frame or one of your layers. – mattwigway Jan 24 '12 at 18:25
the KML file is a polygon. When I "Zoom to layer" it doesn't show anything. – Omega Jan 24 '12 at 18:44
I've never worked with a KML layer in ArcMap, but is it a symbology issue? Perhaps it's not appearing correctly against your background. – Michael Todd Jan 24 '12 at 18:50
if you look at the attributes do you see any features? – Brad Nesom Jan 24 '12 at 20:18
up vote 3 down vote accepted

Ok, it looks like it was a bug and all I needed to do is download the lastest service pack (SP3) from ESRI.

Thanks everyone for all the suggestions.

share|improve this answer
You can always select your own answer as the accepted answer to the question. It "completes" the QA process when you do (plus you get credit, in the form of points, for solving the issue.) – Michael Todd Jan 26 '12 at 18:40

This is an old thread but thought of adding my solution after encountering exactly the same problem as yours and ending up here.

I don't know the exact technicality why the converted KML doesn't show properly in arcgis but if you convert the kml file of the "google earth folder" holding the "specific kml" you want to convert instead of converting directly the "specific kml" file then it shows up properly.

share|improve this answer

I had the same issue. I used the KML to Layer (Conversion) tool to create shapefiles from KML files created in Google Earth.

Result was nothing, UNTIL! I went to "Add Data". After running the tool you'll see a .gdb file with same name as what you thought would be a .shp file.

Select to add that .gdb file and your layer pops right up.

share|improve this answer

This appears to be a really old thread but I recently ran into this same issue using ArcMap 10.3 basic. I ran the tool using python within ArcMap and it worked but the tool from the tool box was not working. Here is an arcpy code:

arcpy.env.workspace = r'ENTER WORKSPACE PATH'
arcpy.LayerToKML_conversion('INPUTFILENAME.lyr', 'OUTPUTFILENAME.kmz')
share|improve this answer
are you trying to say that using the python code brought by you solve the issue? Your answer is unclear. Please clarify it using the edit button. – dof1985 Apr 11 '15 at 19:32
I can confirm that Rob's solution works for ArcMap 10.2.2. I experienced exactly this problem (April 22nd, 2015), namely the toolbox "Layer To KML" tool produces a KMZ which Google Earth does not display. Using the Python code makes a KMZ which is fine for Google Earth. – reroger Apr 22 '15 at 0:39

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.