Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I run into this situation all the time;

I often just copy layers and groups of layers in the TOC of one Map Document and paste then into the TOC of another Map Document.

For the most part this works fine but often enough the Data Source of layer changes when pasted. As a result the pasted layer has the red exclamation mark beside and no data is displayed until I manually set the Data Source.

I confirmed that the Data source of the layer I copy on one document changes when I paste the layer into another document.

This is something that has been happening since the early 8.x version and still an issue in version 10 SP3. It's also not computer specific as i run into this issue on several computer.

Any ideas?

Layer after being pasted:

enter image description here

Source "layer being copied" Data Source: enter image description here

Destination "after pasted in another document" Data Source: enter image description here

share|improve this question
4  
I have seen the same problem. I tried to document it with esri but it is not easy to replicate. –  Brad Nesom Jan 24 '12 at 19:49
    
Does the way that you've set up your folder connections in arccatalog make any difference? –  Kirk Kuykendall Jan 24 '12 at 20:43
    
I am not sure. I usually only have several "Root" directories connected. Is there a preferred way of setting up the connections? Also, I forgot to mention that closing all document and opening them sometimes (not always) works. –  Jakub Jan 24 '12 at 21:10
    
Looking at the images I added I should mention that the directory on the last image does not exist. The drive letter seems to have been substituted. –  Jakub Jan 24 '12 at 21:12

1 Answer 1

up vote 5 down vote accepted

This appears to be related to the map document's (MXD) default database and relative paths. See the ESRI Help for details on relative paths. Relative paths are generally a good thing. I'm not sure if this would be a bug, but is certainly a gotcha.

The resolution is to uncheck the "Store relative paths..." option in the map document properties of the source MXD, File->Map Document Properties...->Pathnames. You should then be able to copy the layers to the destination MXD and maintain the absolute paths. Once you are complete you can switch the source MXD back to relative paths.

An alternative solution would be to set the default database for the two MXDs to the same gdb. This is also accessed from the same Map Document Properties window.

For myself, I prefer to to use UNC paths for network resources. UNC paths largely eliminate issues related to map drives, etc. that can crop up in multi-user, multi-computer situations. UNC paths are not fool proof, but they help.

share|improve this answer
    
I believe it's a relative vs absolute paths also. +1 for benefit of UNC paths. Note however that UNC paths have been known to make an MXD take longer to load (compared to mapped drive letters or relative paths). –  user3461 Jan 24 '12 at 22:07
    
Good suggestions, thanks. I will try at earliest opportunity. –  Jakub Jan 25 '12 at 13:55
    
This works. Obviously a bug with relative paths. Thanks. –  Jakub Jan 31 '12 at 21:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.