Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

Is use of OpenLayers-2.11 ,GeoExt-1.1 and ext-4.0.7-gpl supported . I have only included ext-all.js in the script src. Should I include others too?

share|improve this question

1 Answer 1

up vote 2 down vote accepted

I am pretty sure that GeoExt does not work together with ExtJS 4 yet. You should use ExtJS 3.4.0 like GeoExt does in this MapPanel example.

You also need to add the ext-base.js which you can see in the above mentioned example.

Update:

GeoExt does currently only work with ExtJS 3, but GeoExt is planing a code sprint that targets:

developing GeoExt 2.0 to work with ExtJS 4

share|improve this answer
    
well EXTJS 4 doesn't have ext-base.js. I think same. –  kinkajou Feb 1 '12 at 9:49
    
I did not know that. I have updated the answer because I just saw that GeoExt is planing a code sprint in the spring of 2012 –  taudorf Feb 1 '12 at 10:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.