Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

blah238's very nice answer to this question reminded me of all the time I've spent over the past two years battling against the dreaded geoprocessor memory leak in ArcGIS Desktop.

I only have personal experience of problems with version 9.3.1, but there are numerous threads on the ESRI support pages (e.g. here, here) which suggest that the problem goes back to at least v9.1. blah238's answer and this thread indicate that the problem still isn't fixed at v10.

I know that workarounds are possible, usually involving the use of subprocesses to force the gp to release the memory it's hogging, but they're clunky and often very slow.

This question isn't meant as an attack on ESRI, but I'd be really interested to know:

Why has this problem proved so difficult to fix?

For my work at least, it's a major issue and one that's pushed me away from using ArcGIS for spatial modelling. This has been a great learning experience, but I'm surprised that fixing the problem isn't higher on ESRI's priority list.

share|improve this question
I assume that question is better located at esris forums/channels, isn´t it? You won´t get any answer here unless some ESRI-supporter is here. – HimBromBeere Oct 29 '15 at 7:45

This is actually worse in Arcpy to be honest, and we've struggled for ages to deal with it. We set off processing 400 identical geometries, doing an identical set of processes. It performed the first set in 3 seconds, and the last in 4 minutes, getting progressively slower through the set. When ESRI 'fixed' it in SP1, it introduced new problems, when they 'fixed' it in SP2, it stopped AggregatePoints functionality working, in SP3 it was worse.

Apparently, it is getting fixed in 10.1

We improved performance 20 fold, by simply turning off garbage collecting

share|improve this answer
Interesting, thanks. When I was struggling with this, I tried all kinds of garbage collector options without much luck, but I don't think I ever tried turning it off completely. Definitely one to remember! – JamesS Feb 14 '12 at 10:14
Worked a treat, to speed it up, the memory still leaked, but the gain in performance made the leak that much easier to swallow. Bad ESRI... – Hairy Feb 14 '12 at 13:06

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.