Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I have a recent installation or ArcGIS Desktop on a 64 bit Windows 7 Machine, with 8GB ram, intel core i7 processor, and a solid state drive.

It takes ~2 min to open either ArcMap or ArcCatalog from the start menu (e.g. without loading any data).

As a new installation, I have only the default folder connections.

Is this normal, or is it possible that there is something wrong with my installation?

share|improve this question
    
(1) If you close it and then re-launch it, how much time does it take then? (2) How fast are the devices that support ArcMap and the operating system? (A slow hard drive on a laptop could be a bottleneck.) –  whuber Feb 16 '12 at 20:06
2  
I'm assuming it's fairly consistent - the sluggishness? Are you connecting to a license server on a network? I've found that when I connect to our license server here at work from my home laptop, AM and AC do take longer to launch - but still not 1 minute, more like 15 seconds as opposed to about 3-5 seconds at the office. –  Chad Cooper Feb 16 '12 at 20:08
    
@Chad - I forgot about the license server on a network. That definitely does make a difference. You should make your comment and answer. –  Jakub Feb 16 '12 at 20:16
    
@ChadCooper I am connecting to a license server on a network, and it does say "initializing license" most of the time it is booting –  David Feb 16 '12 at 20:19
1  
If you close both of them and run ArcGIS Adminstrator in the start menu, then "Borrow" the license you want by checking the box and clicking ok, then disconnect entirely from the network (turn off wifi, unplug ethernet), does arcgis open more quickly? It will skip checking for the license and use a local license instead (make sure to return it when you're done). I've found that over VPN, I have to use this method because otherwise everything opens insanely slow. I realize this is not a VPN, but oftentimes traversing a large network like that will create problems. –  nicksan Feb 21 '12 at 18:53
show 6 more comments

5 Answers

up vote 8 down vote accepted

After contacting the appropriate IT admin, I recieved the following instructions, resulting in load times closer to my expectation: ArcMap now takes ~4s, ArcCatalog ~3s to load.

  1. Install ArcGIS service pack 3 (this did not change boot time on its own)
  2. run "esriremove.reg" to remove changes made by ArcGIS to the registry, the contents of esriremove.reg are:

    Windows Registry Editor Version 5.00
    
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Environment]
    "ARCGIS_LICENSE_FILE"=-
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\ESRI\License]
    "LICENSE_SERVER"=-
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\ESRI\License]
    "LICENSE_SERVER"=-
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\ESRI\License10.0]
    "LICENSE_SERVER"=-
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\ESRI\License10.0]
    "LICENSE_SERVER"=-
    
  3. re-install the single-user / off-site license (I had started with the single-user / off-site license, so this is not in and of itself the only issue).

share|improve this answer
    
Glad you found a solution, you should mark this as the answer. –  Chad Cooper Feb 17 '12 at 13:26
    
@ChadCooper I will - tomorrow (when I press the check, there is a yellow popup "You can accept your answer tomorrow"). –  David Feb 17 '12 at 13:53
add comment

ArcMap and ArcCatalog are generally slow to open and many complain about their performance in general.

I have more less the same specs on my desktop (except I have 12GB RAM, not that it matters much since ArcGIS is a 32 bit app, and a 15,000 RPM hard drive) On this machine ArcCatalog opnes in 28 seconds the first time and in 15 seconds the second time I open it.

It seems that SDD (solid state) hard drives makes a significant difference because on my laptop with the same specs you have but with an SDD hard drive ArcCatalog opens in 12 seconds the first time and in 7 seconds the second time I open it. (Same folder connections as the desktop)

Did you try to open new ArcMap document or an existing documents containing layers and data? The speed of opening an ArcMap document is dependent on how much data you have in your document.

As for ArcCatalog, reducing the number of Folder Connections (especially those located on a network) seems to improve performance.

share|improve this answer
    
+1 The speed of opening a MXD (or ArcCatalog connections for that matter) can also depend on network speed. If you open up a MXD that is referencing data over a slow network with thin pipes, it can take FOREVER to open a MXD. Been there, it sucks. –  Chad Cooper Feb 16 '12 at 20:16
    
@Jakub thank you for your help, but none of these issues are relevant to my case, I have updated my question to clarify these points; I have also found a solution and posted the answer below. –  David Feb 16 '12 at 22:57
    
@Jakub, judging from your experience, does it make a difference whether the toolbox side window was opened when ArcMap/ArcCatalog was last shutdown (ie. the toolbox is loaded again upon startup)? I remember opening this window the first time usually takes several seconds... –  stakx Feb 17 '12 at 14:22
add comment

Are you connecting to a license server on a network? I've found that when I connect to our license server here at work from my home laptop, AM and AC do take longer to launch - but still not 1 minute, more like 15 seconds as opposed to about 3-5 seconds at the office. Also, as I mention in a comment in Jakub's answer, if you are referencing data (in a existing MXD of course) over a slow network, opening the MXD or even a ArcCatalog connection can be brutally slow. I used to have to reference data in Houston from Arkansas over small pipes and it was painful, as was the license server connection.

share|improve this answer
    
To clarify, I am not referencing external data or using a slow network (download speeds ~80Mbps). I have found the solution and posted as an answer. Thank you for your help in isolating the issue. –  David Feb 16 '12 at 22:55
add comment

I realize this is an older thread, but I just came upon it, if the above does not help, try to remove old results out of your results window. I had hundreds of old results, and after clearing them out startup and shutdown times for ArcCatalog improved dramatically.

share|improve this answer
add comment

Try this link - it is related to ArcCatalog not opening at all (hanging) and helped me.

http://blog.geocortex.com/2009/06/16/suddenly-arccatalog-won-t-open/

Thanks,

Meryloo

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.