Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I'm trying to define a projection in QGIS. I want to add North America Albers Equal Area Conic. From the spatialreference site I copied the proj4 line:

+proj=aea +lat_1=20 +lat_2=60 +lat_0=40 +lon_0=-96 +x_0=0 +y_0=0 +ellps=GRS80 +datum=NAD83 +units=m +no_defs

Then I went into QGIS -> Settings -> Custom CRS and pasted the following into the window:

enter image description here

But when I go to view the projection within QGIS I see a very different set of parameters:

enter image description here

Is this ok? I don't know enough about projections to tell if the parameters generated are the correct ones, or whether something else is going on. It also ignored the name that I provided which made me suspect the parameters may also be incorrect. I'm using QGIS 1.7.3 on Windows 7.

share
4  
That's not the CRS you defined above. Did you press the save button? –  underdark Feb 19 '12 at 19:12
    
No, I pressed ok. Oops, I will try pressing save and see if it shows up. –  djq Feb 19 '12 at 19:13
    
Ah, that fixed it. I'll write an answer explaining that I should have clicked save before pressing ok –  djq Feb 19 '12 at 19:17

1 Answer 1

up vote 14 down vote accepted

@underdark made me realize that I didn't actually press save while defining the CRS. So, what I needed to do was first click save, and then to click ok. The projection then showed up fine.

enter image description here

share
    
Yes, I've been caught by that one! –  MerseyViking Feb 19 '12 at 20:01
4  
Sounds like a good feature/enhancement request: show pop-up dialog to warn that modified custom CRS has not been saved before closing. In my opinion, this is a pretty common UI feature. –  Mike T Feb 19 '12 at 22:08
1  
Please log a bug report for this. Someone was looking at redoing that dialog at some stage. –  Nathan W Feb 19 '12 at 23:33
    
I'll file a feature enhancement (not sure if it really is a bug). –  djq Feb 20 '12 at 0:58
    
Yes, that got me a few times. Quite frustrating. –  Alex Feb 23 '12 at 3:27

This site is currently not accepting new answers.

Not the answer you're looking for? Browse other questions tagged .