Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

When I add a satellite images as a raster in QGIS: 1. Why the image is changed, it looks like it has only one band?; 2. where is a tool for band combination?

Thanks!

share|improve this question

1 Answer 1

up vote 2 down vote accepted

I don't think the data are changed but I suspect that QGIS doesn't understand how to handle a multiband raster which has more than 3 bands so it defaults to gray-scale.

Once you have imported your raster, right-click on it and go to Layer Properties. In the style tab you have the option to render as a single band or three band (RGB) image. You can specify which bands to use for R, G and B and can tweak the min and max val

share|improve this answer
    
Hi Silvester! Ah! Now I see where is the layer properties. I have QGIS in Russian. Didn't notice it before. Everything works. Many thanks! –  Sasha Feb 27 '12 at 14:34
    
@Sasha Please accept Silvester's answer if it solved your problem. –  underdark Feb 27 '12 at 14:48
    
Would love to accept Silvester's answer, his answer did solved my problem! Thanks a lot. But how to accept his answer? Ok, I see now the tick button. Done! –  Sasha Feb 27 '12 at 15:07
    
Glad to help :) –  MappaGnosis Feb 27 '12 at 15:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.