Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I am trying to implement a Silverlight Web Mapping application with ArcGIS server and I'm trying to use the Token authentication with active directory as the user/roles store.

I have the service running so that I can successfully obtain tokens but when I try to put them in a map service the map service fails with the 'Unauthorized Access' exception.

I have made sure that the account is in the permissions for that service.

I've been on the ESRI forms and I've found about 4 other posts with people with the same problem, but no solutions (I hate ESRI's site).

Hopefully the stack can help.

share|improve this question
add comment

2 Answers

I had a similar problem which was confirmed as a bug, perhaps you are having the same issue if you are using domain logins, check ravi's response:

http://forums.arcgis.com/threads/36199-Bugs-Issues-with-Token-service-%28and-iOS%29

share|improve this answer
    
I tried creating the token in the 'GetToken.html' Page and hard coding it into the service. This gave me a different exception (Token invalid). Tested it with different referrers to find if the referrer is wrong the token is invalid. Ok so then with the referrer that gives me 'Unauthorized Access' i tested different declaration of my user name; all instances still give the 'Unauthorized Access' I tried adding myself to a local group and a Domain group that has access to the Map Service. Man, what could be the problem..... –  DrStereo Feb 28 '12 at 23:12
add comment

Solved it - Three things contributed to this:

  1. The user name needed to be companydomain\username instead of companydomain.com\username, which I have been using because our company has an identity issue i wont go into detail about.

  2. If Anonymous is on while Windows Authentication is on it will try to use the Anonymous account which is not authorized to get the services.

  3. I was testing the token call with the 'clientid=ref.https://...' parameter loaded which in silverlight you can only use the IP address.

I also created a couple outbound firewall rules on the ArcGIS Server so I may go back and test to see if that had anything to do with it as well.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.