Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I am trying to incorporate a simple spatial join in a model but the spatial join options in model builder are different from the right click-->join options. How can I do the join as in the image below in the data management-->

enter image description here Above process works fine but I have to do it manually.

The process below fails/doesn't give the result I want and I need to incorporate this in the model as otherwise I have to do this manually and then complete the process in a second model.

enter image description here

share|improve this question
    
Is this because when you right click join, that is an attribute or common attribute column join. Where as a spatial join is a join based on features from one spatial dataset intersecting feature from a second spatial dataset. They are different types of joins. –  Justin Mar 8 '12 at 1:02
    
The right click join has two options at the top, an attribute join and spatial join as per the image in my question. –  GeorgeC Mar 8 '12 at 1:14
    
Are they both in the same coordinate system. I know in the python runtime there is some coordinate system switching that was happening to me and I wasn't get the expected results. After I would loop through some spatial intersections I had to re-set the "dataframe" or environment to get accurate results. Perhaps model builder isn't taking care of some on the fly projecting for you like you think. –  Justin Mar 8 '12 at 1:20
    
I'd start by reversing your Target and Join Features - you appear to be wanting to join values from your Buffered Tower Range polygons onto your target Signal_Strength_Added points but have the opposite in your Spatial Join dialog. –  PolyGeo Mar 8 '12 at 1:20
    
What is wrong with the result? It looks like it should be the same join to me. Are you sur"e you don't have "Target Features" and "Join Features the wrong way round in the Toolbox Spatial Join? –  Stev_k Mar 8 '12 at 1:24
show 3 more comments

2 Answers 2

I am closing this as the issue was based on the size of the dataset and not any real difference with the tools. Thanks for all your comments -especially @PolyGeo. Further info is at http://stackoverflow.com/questions/9612882/split-a-large-text-xyz-database-into-x-equal-parts

share|improve this answer
add comment

From the screenshot you appear to be wanting to join values from your Buffered Tower Range polygons onto your target Signal_Strength_Added points but have the opposite in your Spatial Join dialog.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.