Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

My QGIS project has two layers - one retrieved from GADM (administrative boundaries of Guinea Bissau) and another one of the villages collected in the field using GPS Decimal Degrees - D.ddddd. If I have in Settings - Project Properties - CRS - Enable 'on the fly' CRS transformation clicked on, these layers no longer overlay. If it is off it is not possible to know distances in Km. It would be great if someone has a clue about what is going on... Thanks! Ila

share

2 Answers 2

It is likely that the wrong CRS is applied to one of your layers. The .prj file associated with shapefiles does not always contain enough information for QGIS to assign a CRS to the layer. I forget the stock settings, but QGIS will apply either the current project CRS or predefined CRS to layers of unknown projection. (You can alter the behavior under Settings-->Options-->CRS to propmt you when the CRS is unknown. Handy if you work with exotic projections.)

To check and manually assign CRS to each layer, right-click the layer and choose Properties, select the General tab, and use the 'Specify CRS' button if the CRS listed there is incorrect.

Drop a note if you cannot discern the CRS of your datasets.

share

You need to make sure the correct coordinate reference system (CRS) is specified for all the of the layers in your project. When that is specified, all of the layers will line up and QGIS will be able to calculate the kilometre distances.

Right-click on each layer and 'Set layer CRS'. From the following dialogue, select the CRS for the layer. If you don't see the CRS you need, type part of the code in the 'find' box, and then select it from the list presented below. The 'recently used' list will remember the last four or so CRSs you have selected.

GPS downloaded data is usually in the WGS 84 (unprojected) CRS (which will be just 'WGS 84' with no following '/' and other text). Your basemap (admin boundaries) is most likely in UTM Zone 28N; see the example below where 28N is in the 'find' box: enter image description here Once you've set each layer's CRS correctly, confirm that 'on the fly' is set for the project.

share

This site is currently not accepting new answers.

Not the answer you're looking for? Browse other questions tagged .