Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

internet -- router -- reverse proxy server -- arcgis server

Had this config. working great, after following this proxy server setup tutorial: http://support.esri.com/en/knowledgebase/techarticles/detail/39568

I was able to see all services by visiting my external facing FQDN: hxxp://mydomain.com/arcgis/rest/services

I could click on the "view in Javascript" link on the services page and was able to preview the service; all was well.

I then installed SSL cert. on proxy server, communication from proxy to gis server is over port 80, not encrypted. I updated the rest.conf file on the gis server and an now can browse: hxxps://mydomain.com/arcgis/rest/services, all the services are listed.

however, the view in javascript does not preview the service. the viewer loads, but the service's content does not load.

Here's the firebug error: GET MapServer?f=json&dpi=96&transparent=true&format=png8&callback=dojo.io.script.jsonp_dojoIoScript1._jsonpCallback 404 not found

the URL for the above GET request is wrong,

The issue is http:// If it were https:// it would work

In the meantime, I just added a premanent redirect to the proxy server httpd.conf, but this is a work around.

anyone have any advice?

share|improve this question
    
I'm currently having the exact same problem, but only with cached services. However, on mine it also adds the port. For example 8080. So I need to add the "s" for https, and have it remove the port number. Did you ever find a fix? Was the redirect a pain? –  Evan Apr 10 '12 at 21:01
    
Apparently I can only edit for up to five minutes after adding a comment. I was wrong on it only not working with cached services. It doesn't work on any of them through the domain name. –  Evan Apr 10 '12 at 21:08
add comment

1 Answer 1

up vote 0 down vote accepted

our problem was similar to yours. I had several issues, that aren't addressed here, and also found some limitations in the software. I can’t say that I’m 100% sure it’s set up correctly, but it’s working from the fully qualified domain name. To use SSL properly through the reverse proxy the connection to your ArcGIS Server must also be using a secure connection. Essentially when using SSL you’ll want secure not only from the reverse-proxy, but also to the ArcGIS Server machine.

I started with changing IIS to require https for the ArcGIS Server machine. For IIS 7 on your ArcGIS Server machine setting up SSL is fairly straight forward. This link takes you to esri's website for instructions on setting up the SSL through IIS. They recommend a signed certificate, but we used a self-signed certificate on the ArcGIS Server machine. This saves having to pay a company like Verisign twice (once for the reverse proxy, and the other for the internal ArcGIS machine). Internal users that consume the services through an internal link will get a security warning. However, external users that follow the FQDN will not get a security warning, assuming your certificate on the reverse-proxy is a certified signed certificate. Once the SSL is setup on your ArcGIS Server machine, and has been tested, make changes to the httpd.conf file to reflect the https. (See code snip below.)

When setting up the reverse-proxy I found what, I think, is a better document to follow. This document was written for 9.2, 9.3, and 9.3.1, but still works for 10. While talking with esri support I asked why this document was 15 pages versus the other 3 page document for 10. Their short answer was that not everything was needed from the 15 page document. However, the 15 page document seemed to make more sense to me.

Once I had IIS on the ArcGIS Server machine requiring SSL I set the proxy passes in Apache to read https://... I also followed the instructions to use case-insensitive found in the 15 page document. Example:

ProxyPassMatch (?i)^/[arcgis_instance]/rest/services/(.*) https://[ip_address]/[arcgis_instance]/rest/services/$1
ProxyPassReverse /[arcgis_instance]/rest/services/ https://[ip_address]/[arcgis_instance]/rest/services/

Our instance on our ArcGIS Server was set to use port 8181 instead of 80. DON’T DO THIS! This is where there is a limitation in the software working with SSL. Our IT Department was using port 80 for some reason when we first set ArcGIS Server up on that server, and told us to use a different port. We had to re-install our instance of ArcGIS Server. The port 80 install in ArcGIS Server works alongside with port 443, so you won’t have to re-install your instance if set up to use port 80.

Edit your rest.config file to reflect the correct port and https. Example:

<SoapUrl>https://[fqdn]/[instance_name]/services</SoapUrl>
    <SoapSslUrl>https://[fqdn]/[instance_name]/services</SoapSslUrl>
<SslPort>443</SslPort>
  <ReverseProxyPort>80</ReverseProxyPort>
  <ReverseProxySslPort>443</ReverseProxySslPort>

If using the .NET wizard for .NET applications, edit the ApplicationBuilderConfig.xml found in C:\inetpub\wwwroot[instance name]\Manager\App_Data. Change the <DefaultHttpScheme> to https:// instead of http://.

One other thing we changed, though I don't know if this did anything, was we inserted SSLProxyEngine On just before the proxy passes.

I hope this helps. If you think I'm missing anything or have any questions please let me know, I'll be glad to try and help.

share|improve this answer
    
thanks Evan. After talking with ESRI I ended up doing almost exactly what you stated in your post, down to usign a self-signed cert for the internal-only ArcGIS server and a CA signed cert. for the Apache reverse proxy. One other thing I had to do was go into manager and look at the properties for the folder my service(s) are published in. There's a check box for 'require encrypted web access'. –  dan May 7 '12 at 19:28
    
At the end of the day, would we buy a hardware/software bundle from esri again..........ABSOLUTELY NOT. I ended up re-config'ing everything, specific to our network. –  dan May 7 '12 at 19:30
    
Yeah, I forgot that portion about requiring encrypted web access. I'm definitely disappointed with esri and their lack of help on this issue, especially when it's something they recommend doing. We also have the GeoPortal software, and trying to find anyone at esri that knows that is a joke. –  Evan May 9 '12 at 14:42
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.