Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I'm having issues viewing a ArcGIS93Rest layer on both sides of the dateline -- the data doesn't cross the dateline. The problem is that i only see data for one side of the dateline until i pan west and vice versa (see attached pics at bottom).

I'm trying to rule out that it's an OpenLayers problem. The wrapDateLine option should work with the ArcGIS93Rest layer type because it's a subclass of Layer > HttpRequest > Grid same as OpenLayer WMS Layer. I have no wrapping problems with WMS layers created with UMN Mapserver.

However, I can't set the wrapDateLine option as a hash extra option on the ArcGIS93 layer but only after intializing a layer like so. I'm not sure this is right. Is it?:

layer = new OpenLayers.Layer.ArcGIS93Rest('L' + cfg.id, cfg.url + '/export',
    { layers: 'show:' + cfg.layer, transparent: 'true',
        f: 'image', format: 'png', size: '256,256',
        bboxSR: '900913', imageSR: '900913'
    });
layer.setOpacity(cfgOpacity);
layer.wrapDateLine = true;

Questions:

  1. Does anyone know if wrapDateLine works with ArcGISRest93? Have you seen it work?

  2. Has anyone had this problem with ArcGIS Server data before? I'm wondering if it has to do with their service. As I said before, I have no problem with WMS layers from UMN Mapserver

west of dateline

east of dateline

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

In response to my questions mentioned above:

Questions:

1) Does anyone know if wrapDateLine works with ArcGISRest93? Have you seen it work?

2) Has anyone had this problem with ArcGIS Server data before? I'm wondering if it has to do with their service. As I said before, I have no problem with WMS layers from UMN Mapserver

1) Yes, it should and does work just don't trust the OpenLayers documentation on the ArcGIS93Rest constructor. Like the OpenLayers WMS layer the ArcGIS93Rest layer takes two hash objects -- one is params and the other is options. So you need to pass it like this:

layer = new OpenLayers.Layer.ArcGIS93Rest('L' + cfg.id, cfg.url + '/export',
{ layers: 'show:' + cfg.layer, transparent: 'true',
    f: 'image', format: 'png', size: '256,256',
    bboxSR: '900913', imageSR: '900913'
}, { wrapDateLine: true });

2) Yes, i continue to have problems with a certain ArcIMS WMS layer

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.