Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I have been having this problem too often.
My only fix is to shut down arcmap and restart.
I can't find why it is happening.
Anyone else see this? export to pdf watch it go all the way through and when it should show the file progress (processsing) bar it just goes away and says export complete, but the file is 0kb. arcmap 10.0 sp 2

Not only have I tried refresh, restart, shutdown. I have tried to open the file. the message is...

0kbfile
It seems there is something to do with either the original file or arcmap.
I tried to create a jpg "export" from arcmap and get the "can't map metafile to memory" error.
But another document will export both pdf and jpg.
Then a coworker opened it and exported immediately. It also occurs on other machines though.
I cnan't nail down any consistent behavior except that it always doesn't show the file status bar after processing the data and successfully writes a file (0kb).

share|improve this question
1  
Maybe update to sp 4. resources.arcgis.com/content/… –  artwork21 Mar 23 '12 at 2:00
    
Tend to use a pdf printer driver - primopdf.com is stable and has some useful additional tools. ArcMap is hideously bad at exporting - export to .AI and Illustrator/Photoshop for the pro stuff. –  Mapperz Mar 23 '12 at 3:33
    
I gave a +1 to @artwork21 because being updated to the most current version is always a good idea. I wanted to add though, that I've run across this same phenomenon. It turned out that the pdf did export correctly. Simply refreshing the export directory updated the pdf's properties to show the actual size. –  Get Spatial Mar 23 '12 at 8:36
1  
My troubleshooting with exporting has usually involved limiting the scope of the problem by disabling layers to see if that fixes it (I've had exports crash due to basemaps), disabling data driven pages (if enabled), and trying to copy the layers and styling to a different map document (new) to see if the problem replicates. My experience is that most export problems are tied to map documents (and sometimes map documents on specific machines). Start there, and see if it fixes it - also, I second (third) the update to SP4. –  nicksan Mar 27 '12 at 19:37
    
Thanks Nick, I have done the sp4 on one machine. And the troubleshooting is tough to carve out time for. Seems like it always acts up when the crunch is on. Then there are a hunred other things to do when it cools down. But you are right. It is easier to identify when you make small one step changes. And I have always had some suspect of the MXD and a machine. –  Brad Nesom Mar 28 '12 at 14:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.