Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I'm really confused by this. ArcMap will seeminly randomly decide to not allow snapping when editing. Sometimes its only for certain features, sometimes for only parts of the same feature (e.g. one end of a line but not the other, or not along a part of the line). Now its just flat out not letting me snap to anything (yes, snapping is turned on with all options on). Any hints on this one?

share|improve this question
I get this too. My workaround is to click on a different tool in the editing menu then click back to the tool I was using which seems to bring the snapping environment back to life. –  Jakub Mar 23 '12 at 15:49
I've discovered that the feature will snap to other features at the X at the center of the feature. You can move that X by holding down the Shift key while you're using the Edit Tool, where it can snap to vertices or edges. –  kenbuja Mar 23 '12 at 16:02
Hehe, one of the many buggy things about ArcMap. Sometimes you just have to shut the whole thing down. Every now and then we are reminded that software is not perfect. –  dchaboya Mar 23 '12 at 16:07
It seems to me that the lack of snapping can be associated with certain MXD files - I just rebooted and still couldn't snap, yet took the same features into a new MXD and the snapping worked. so there must be features in the original MXD that aren't compatible with snapping, or maybe it is just a bug. –  Ian Apr 20 '12 at 5:20
@Ian ah yes, the solution for a myriad of problems with ArcMap - pull all your layers into a new mxd. –  Cindy Williams Jan 25 '13 at 5:02

9 Answers 9

up vote 1 down vote accepted

I had the same issue, but a friend said that I should use classic snapping to help select the layers I wanted to snap to. The classic snapping was a simple work around to the issue.

share|improve this answer

There are several steps I use.
1. is easiest but don't necessarily try it first. copy the layer you need to edit, snap to and use for reference (as few as possible) to another document (for editing).
2. make sure you are not in the layout view.
3. make sure you don't have a definition query.

share|improve this answer
+1, excepting ensuring not in Layout View should be first step (easiest to test). –  matt wilkie Nov 19 '14 at 18:13

I discovered that snapping won't work if the layer you're editing is in the Map Document more than once.

share|improve this answer

What Brad said (especially make sure you're in data view - focus your data frame or edit in data view rather than layout).

You can also tighten your snapping tolerance. Under the snapping drop down arrow, select "options". Change the number value shown in my printscreen below. Sometimes this works for me. I've seen instances where this seems to refresh my snapping capability. Usually, I just don't have my data frame focussed though.

enter image description here

share|improve this answer
absolutely this is the solution. re-activate your data frame (even if you are not in layout view). I will try the tolerance test next time it goes away. +1 –  Brad Nesom Aug 14 '13 at 17:21

I had this "no snapping" problem, and the eternal blue circle pause when trying to edit. I had a huge file of contours on my map which were in a different projection than the map. I got the warning whenever I turned on editing, but I just ignored it. When I turned off the contours, suddenly snapping and editing worked fine!

share|improve this answer

I was able to resolve this issue by doing the following: From the Editor Window --> Snapping --> Snapping Window and set the Snapping Environment. I was able to snap my vertices to the specified layer this way.

share|improve this answer

I just usually quit the map I am working on, and then restart it and it typically works again.

What I have noticed is it has trouble when the mxd has too many layers or grouped layers. I have not checked but I wonder is the cache being to full or needing a purge may help.

share|improve this answer

I had an issue where the editor would not even select a certain point feature. I would have to select it with the "Select Feature" tool and then it could be moved but it would still not snap to the line feature.

Not sure why this worked but I turned on a different point feature and was able to select it with the editor and could snap it. When I went back to the orginial feature I wanted to snap it worked.

share|improve this answer

I had the same issue, and the only solution that I found was to only select the specific snap one at a time, for example, only activate "end point snap" and deactivate the others, I hope this works.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.