Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

The FME licence I have access to is a floating one.

The issue seems to be easy to recognize (see attached log) however there are some doubts I would like to ask for.

While the process is really machine consuming I have some suspicious that the error of the FME is not due to "Failed to validate FME worker licence key" but it's more related to the task the machine has to deal with. Can it be ?

The error always occurs in the same point of proccessing time.

How does FME check for the licence key ? Just at the start of the workbench or there are some "milestones" during the processes where the licence has to be confirmed again ?

Please find below a part of the log.

Thanks in advance for the help.

Gregory


Failed to validate FME worker license key. Program Terminating Translation FAILED. Failed to validate FME worker license key. Program Terminating Translation FAILED. Failed to validate FME worker license key. Program Terminating Translation FAILED. ... Last line repeated 2 times ... FME Session Duration: 4 hours 56 minutes 38.5 seconds. (CPU: 220.4s user, 11.6s system) END - ProcessID: 1324, peak process memory usage: 1074456 kB, current process memory usage: 355076 kB Error in child process '33', exited with code '2' Program Terminating Translation FAILED. Warning: not all FMESessions that were created were destroyed before shutdown. This may cause instability

share|improve this question
    
What version of FME (and build number) are you using? –  Mapperz Mar 28 '12 at 14:19
    
Is there actually a crash, or does FME just exit after the licensing failure? –  Raven Mar 28 '12 at 16:04

4 Answers 4

up vote 1 down vote accepted

Can you check the license with Help > About in Workbench? The only place I can find a reference to that error message is for evaluation licenses.

share|improve this answer

Are you perhaps using the WorkspaceRunner transformer, instead of parallel processing? Just a thought. Maybe you are firing off too many jobs at once? Parallel processing should cap itself to prevent any problem, but WorkspaceRunner might not.

share|improve this answer

Thanks for all the answers.
Good hints but the issue still seems to occur.
@Mapperz - Edition: FME Desktop Oracle Edition (floating), Version: FME(R) 2012 SP1 (20120217 - Build 12224 - WIN64.
It's not a crash (sorry for ignorance) FME just stop the >process and log the issue the way I posted earlier.
@Mark - WorkspaceRunner transformer is not in use.

@Raven - It could indeed make a trick but the data I deal with are so big that there is no other option instead of using Parallel Processsing (PP) - this is actually the reason I deciced to design the process in FME - and to get result in reasonable time.
The workbench has been run earlier on smaller datasets with PP on without any problem - this make me think that the size of the data is the problem.

The workbench heavy uses linejoiners, dissolvers, cllipers, bufferers all using PP, so > what about workaround like:

Split the workbench into couple parts using WorkspaceRunner where each separate instance > will partly processes the data and make output for the next FME instance in the line ? Does next instance of FME in the batch use all memory/ resources droped(?) after exit > > from previous instance ? Would like to know before trying to redisign process.

I familiarize myself what's the idea behing WorkspaceRunner and it seems not to be a right tool for what I want to achive. I was either thinking about the scenario where the heaviest part of the proccessing will be proccesed in couple separate workbenches one by one (each next workbench will get the ouput from previous one and procces it further). A simply run of couple workbenches in batch mode would be better I guess.

share|improve this answer
1  
I recommend you submit a bug report (ideally including log, workspace, and data) to Safe Software: fmepedia.safe.com/knowledgeSubmitCase? –  Raven Mar 29 '12 at 16:00

As a workaround, check your workspace for transformers that contain "Parallel Processing Level" options, and change those to "No Parallelism".

More information on FME's parallel processing.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.