Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

The dataset contains about 70,000 point features. And I want to use spatial join tool in arctool box, to join a polygon feature.

But it went that the values in the joined column are all zero, values in the 'join_count' are also zero .

And the result was right when the point dataset is not that large(actually 40,000 is OK). What's the problem? Do I have any solutions?

p.s. I don't want to use the join function in the right-click join. Although it went right, but I want to do spatial join using Geoprocessing.

share|improve this question
    
Two first thing to check would be lack/erroneous projection of one of datasets. Or misspecified parameters of the spatial join. Which particular options have you chosen? –  radek Mar 31 '12 at 16:30
    
The datasets are projected actually. And no parameters are missed. In ArcMap, spatial join can be done, and the message box showed that it was completed. But just when I checked the result, values were all 0. –  Vivian Apr 2 '12 at 12:51
    
The problem is, when the dataset is smaller, it works good! –  Vivian Apr 2 '12 at 12:52
    
I had the same problem as Vivian and the work around of slimming down the number of features does work. Is there a way to avoid this? Maybe download latest service pack? –  dchaboya Aug 9 '12 at 3:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.