Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a serious problem: on Wednesday, April 2 OpenSUSE 12.1 is updated, and the package was to update the PostGIS-a version 1.5.3 to 2.0.0. After this operation, Postgres does not display records. In pgAdmin count the records, but seeing them in a table view, and by SELECT is a problem. I can not do dump: pg_dump-h 5432-U postgres-Fc-b-v-f "/ home / admin / olddb.backup" Tomice

I get the message: pg_dump: SQL command failed pg_dump: Communication error with server :: ERROR: can not access the file "$ libdir/postgis-1.5 ': No such file or directory pg_dump: Your command: COPY public.armatura (gid, type, sub_typ, description, wys_g, wys_d, operator, the_geom) TO stdout; pg_dump: *** stopped because of an error

In view of the tables in PgAdminie my tables, I have a good number of records, but when you call the data is still the same.

I noticed that almost all functions have the following address: "$ libdir/postgis-1.5" that during the upgrade-u has been replaced by / PostGIS-2.0. I could perhaps remove the column geometry, but at the base of my ...

I attach screenshots of pgAdmin. Command did not help, sql for good-sounded names: postgis_upgrade_2.0.sql etc. .. Suddenly all the repositories of RPMs flown for PostGIS 1.5.3, and I can not go back to the old version ... At stake is 1 working day to 15 people. If anyone has any idea - I'll be bound.

I have no idea to solve this problem.

share|improve this question
If the question has been answered you should accept an answer for future users. – Roy Nov 14 '12 at 17:52
Please do not put "SOLVED" in your Question title - the way to indicate that you have a solution is to either click the Accept button next to the most helpful Answer you received, or if none led you near it then write (and Accept) your own Answer. – PolyGeo Apr 23 '14 at 9:00
up vote 6 down vote accepted

Revert your software to 1.5, then follow the HARD UPGRADE instructions in the manual, doing the dump step, then the software upgrade, then the restore steps.

share|improve this answer
Hi, its really great that in a few hours my problem was resolved. After revert the PostGIS to 1.5, I had all my data back. Your answer was really helpful. Thank you a lot. – tomsik Apr 6 '12 at 6:14
The link moved to… – alfonx Apr 15 '12 at 19:33

I am a maintainer at Application:Geo. I will restore postgis 1.5.3 binaries in the next few hours.

If you are in a hurry check where the old binary is posted now.

Thanks for the report, Angelos

share|improve this answer
All done ! Thank You for help, the repository was changed, I was revert the PostGIS to 1.5.3 and all my databases back! I didn't expect that quick and professional response. I describe this case in the Polish forum QGIS. Thanks a lot Angelos. – tomsik Apr 6 '12 at 6:05
@tomsik Please accept the answer if your problem is solved. – underdark Apr 6 '12 at 6:55
after the 15 reputations :-) only ... – tomsik Apr 6 '12 at 9:37

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.