Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I have been trying to figure this out for a couple weeks now and have had no luck getting the buffer tool to accept anything but degrees as units of measure.

I have found lots of stuff saying the layer needs to be reprojected and saved but it hasn't worked at all for me. Is there a way I could create a buffer without using ftools or at least force the units to meters somehow?

As a workaround I converted meters to degrees (lat) and used that but the final product needs to be as close to reality as possible.

Things I've tried:

  • setting every unit option I could find to meters (where possible).
  • setting everything to NAD83/Maryland (data is for Washington, DC) and saving it as such (as layers in ESRI shape files).
  • reimporting the reprojected layers
  • setting relevant layers to Google Mercator

The was tried followed by creating a buffer. Many were tried in combination. QGIS 1.7.3 Slackware64 current (qgis from SBo-13.37 repo, tried on multilib and plain 64it with same results)

share|improve this question
add comment

1 Answer 1

up vote 15 down vote accepted

The buffer size is always applied in the layer CRS units. Therefore, the layer CRS has to use meters if you want to buffer in meters.

You don't need ftools to change the CRS.

  1. Open the original layer in WGS84 CRS.
  2. Right-click in layer list and select "Save as ...". (DON'T change the CRS in layer options!)
  3. Set the target CRS to NAD83/Maryland and save.
  4. Load the new Shapefile.
  5. Buffer.

Update:

The point coordinates in the linked files have not been reprojected correctly:

enter image description here

These are the settings in "Save as ..." that work for me:

enter image description here

share|improve this answer
    
The point in the Shapefile has the same coordinates as the point in the KML. But the Shapefile says its CRS is Google Mercator. The coordinates would have to be different. The coordinates have not been reprojected. How did you create the Shapefile? –  underdark Apr 21 '12 at 17:59
    
I made several iterations of the shp file. I originally had it projected to NAD83/MD and the last thing I tried was something else on this site that suggested Google Mercator. I created the shp files by importing them into QGIS and then saving them as ESRI shapefiles with NAD83/MD projection (or Google Mercator in that last instance). –  haxwithaxe Apr 22 '12 at 17:37
1  
I started over and exported the KMLs to shapefiles without touching them and then did the reprojection and buffering and it looks like it's working. –  haxwithaxe Apr 23 '12 at 4:53
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.